Photographer - Camera Exposure, White balance, Autofocus and Physical Lights

OK, silly me. I hide windows in viewport but not delete them, and they apper in render :slight_smile: causing less light to fall into the scene

1 Like

Glad that you found the issue :slight_smile:

after whole night of rendering brain don’t work as quick :slight_smile:

BTW I love your addon from version nr 2 :slight_smile: NICE JOB, i love render with depth of field again

Where to find 3.1.5 ?

If you haven’t found it yet: https://gumroad.com/l/cQTgl

I only have 3.1.2 on the blender market mate. Not 3.1.5

3.1.2 is the latest version available!
I assumed the 5 was a typo :slight_smile:

Cool cheers :slightly_smiling_face:

@sick I think I have found the report for your problem
https://developer.blender.org/T77909

thanks! :slight_smile:

@chafouin Hi I found an issue that Photographer has with the latest new Eevee object based motion blur in the latest 2.90. The initial implementation of the motion blur was fine despite being a little unstable, but the recent addition of the “Steps” setting just does not work with Photographer at all. It is almost guaranteed to crash every time when Photographer is on. If you turn off Photographer, it can render jusr fine. Here is the error log:

Error   : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF60A59C257
Module  : blender.exe
Thread  : 00003ed0
Writing: C:\Users\Eary\AppData\Local\Temp\Test Eevee Motion Blur 2.crash.txt

EDIT: The same error occasionally occurs without Photographer, but it happens every time with Photographer. Strange.

1 Like

It’s related to the frame_post_render handler to support custom properties animations.
I didn’t see any recent change to the depsgraph in 2.90 so I’m not sure why this happens now. I’ll try to find a quick way to fix it.

EDIT: @Eary_Chow Today’s build (June 25th - 62aa103d485f) seems to be working, can you confirm?

1 Like

No, the same error on my end, it stilll crashed instantly when pressing render.
The branch is 2020-06-25 hash: 62aa103d485f on Windows.

Photographer definitely increase the crashes frequency when using Steps 1, but I don’t think is it the real cause of the issue. Even if I remove the frame update handler, I can still get Blender crashes.
The crash has been reported (https://developer.blender.org/T78329), let’s see if gets fixed in new builds.

I have already noticed the crash happens less often with recent builds. It used to appear 100% on the first frame, now it’s less often.

1 Like

I don’t know why but I still get 100% crashing frequency now, and I get also no crash at all when Photographer is turned off. Here is my testing .blend file:
Test Eevee Motion Blur 2.blend (836.8 KB)
You don’t need to change anything, just hit render after opening the file, then you will see the crash.

Thanks for the test scene, I am able to reproduce the issue. I have looked at it and tried different things, but I couldn’t find an easy fix, and I don’t have time to focus on this issue at the moment. Blender 2.90 EEVEE motion blur is still very experimental, and you can work around the issue by turning off the Exposure control in Photographer.

I apologize for the inconvenience but I need to focus on the next update for 2.83 which will include many improvements. I will try to get in touch with devs to find a way to fix it.

4 Likes

New version 3.2 is available:

New features:

  • Auto Exposure
  • Negative lights support
  • EV guide is now visible in the 3D view panel
  • Fisheye lens support (can be used to add distorsion at longer focal length)
  • Exposure and White Balance panels now available in Image editor

Changed:

  • MasterCamera Transition speed now works as speed instead of “slowness”

Bugfix:

  • Fixed division by 0 when using black color in the light.
  • EEVEE Light sampling threshold button wasn’t unregistered properly
  • Fixed white balance picker with ACES (currently using Raw values)
  • Fixed wrong light unit conversion when using drivers
  • Fixed end playback error when using Autofocus animate

A video tutorial about the new features will be coming soon on my Youtube channel!

8 Likes

Thanks fro this! Chafoiun!

Very useful.

Cheers,
Pato.

1 Like

Bug report, Auto Exposure does not work if Luxcore is not on. Even if I am only using Eevee and Cycles, I still need to turn on Luxcore in the preference settings, otherwise it stays at the blender default exposure.
P.S. The Auto Exposure does not seem to support animation so far? Will there be a keying switch or something in the future?