Photographer - Camera Exposure, White Balance, Autofocus, Physical Lights, Bokeh, Render Queue

Hi, I am trying to render 9 CAMs for different frames using render Queue but it gave me only the current frame 624 for all CAMs
is there any way to make the render Queue works on different frames?

Also, I have a bug animating DOF and Focus Distance it doesn’t update in real-time in the viewport render
but it updates in the final render that makes it hard to edit in real time

Open the Camera subpanel, check Frames Override for each cameras and set the frames you want to render (it can be the same Start and End if you want to render single frames). You may have to use the Animation rendering button instead of Still, I have a doubt there.

Do you have AF-C turned on?

Hey Fabien,

Thank you for this great addon :slight_smile:

I just encountered a little problem:

I use Photographers light settings to set the power of a light and animate the power with a couple of keyframes.

It all works perfectly when rendering on my computer.

When I try rendering it on a renderfarm (without the photographer addon) the keyframe animation is not working, because the light power animation is only keyframed for the “photographer.power” and not for the default blender “power”.

Would it be possible to update this, so keyframes added to the Photographer specific power, are copied over to the blender internal “power”, by the addon?

Hi Matt,

Are you using the Export Render file button in the Render Queue Panel? It is made exactly for this: baking all Photographer settings into Blender settings in order to export a .blend scene that can be rendered on a renderfarm that doesn’t have Photographer installed.

Let me know if that doesn’t work, then it’s a bug that I should fix.

1 Like

Thank you for the super quick reply :slightly_smiling_face:
And that indeed works perfectly! Thank you, I totally missed that.

1 Like

Version 4.8.6 is now available:

  • Fixed Dolly zoom when using Camera Rigs @nickberckley
  • Fixed Background render when using Turbo Tools
  • Fixed Background render when using Overwrite File Output nodes @wilBr

As you may have noticed, LuxCoreRender development has stopped. While I think this is a great renderer, I do not see it being used in many productions or architectural visualizations, and that number will keep declining. Cycles on the other end is getting better every release and I can see more and more professionals using it.
I don’t have enough hours in the day to develop all the features I’d like to, and I’m considering dropping LuxCoreRender support to make it easier for me to focus on Cycles, EEVEE and other new Blender features.

What do you think? Should I keep supporting LuxCoreRender in Photographer 5?

  • Yes, I still use LuxCore
  • No, please focus on EEVEE and Cycles

0 voters


Please make it Octane compatible :smiling_face_with_tear: I’ll love you forever bro

1 Like

I found a strange bug with white balance/exposure picker. If I have a layout like this, with 2 3d viewports side by side, then the pickers don’t work correctly in the right viewport. Basically they only work in the screen area that’s to the right of the blue line.

The effect of this bug is quite inconsistent, and the exact place where the pickers stop working is dependent on how far left or right the divider between 3d viewports lies. If it’s too far to the right, then they don’t work at all.

Thanks, the mouse position should be queried from the region area, but from your description it looks like it’s taking the screen position. I’ll look into it!

Hey Fabien!

Absolutely love this addon! It’s saving me a ton of time and helping me get better renders.

I was wondering, is there a way to keep sensor info from imported cameras? I export fbx cameras from Photomodeler and noticed that after installing the addon the sensor width is being overridden and defaulting to “Fullframe” instead of using the exported values. Is there a way to default imported cameras to using the custom sensor size they were exported with?

All the other lens info imports correctly, it’s just that sensor width stuff that’s getting lost.

Thanks in advance for any advice!


Hi David,

Thank you for reporting the issue, I’ll see what I can do to not override custom sensor sizes. I used the same sensor size default as new cameras created in Blender, but if you import new ones, it will indeed not retrieve these values.


I appreciate you letting me know and looking into it. It’s something I can work around without too much trouble but would be a nice, albeit niche, update.

Cheers and thanks again for creating such an awesome addon!

Hey @chafouin
Small feature request
Is it possibe to add tigny button for the Pie Menu for switchin to the Orthographic camera? (pobably near Focal length)
And probably scale option?
That would help a lot, I almost not use panel, but swiching to the ortho only thing wich make me do that all the time, this is so annoing to to this just for one click!

1 Like

@chafouin I think this isn’t something achievable with an add-on, but I’ll ask anyway: any chance you can tweak Blender’s composition guides look?

They always looked too faint to me, especially with busy scenes they really get lost, with their color too muted, and being the lines too thin.

Or, maybe adding an option to have custom lines with different colors and thickness from Blender’s built-in ones?

Edit > Properties > Themes > 3D Viewport > View Layout
at least can change the Composition Guide colors.
I couldn’t find a way to change the size.

view overlay to change composition guide colors


I totally overlooked that.
Thanks, @HelloHiHola that helped!

Hi! Can you suggest how to configure highlight compression in blender(cycles) as in corona render. It’s possible?

Hi _AD, this is unfortunately out of the scope of an add-on, the correct way to do highlight compression is by using the right tonemapper in the Color Management.
Is there any reason why Filmic doesn’t work for you? Have you tried other OCIO configs like AgX (or ACES gasp)?

I mean reduce the brightness of the white sphere and keep the brightness of the interior. I probably didn’t set up the lights in the scene correctly

interior_test.blend (2.8 MB)