Physical Starlight and Atmosphere Addon for 2.9 (v1.4) - now with Clouds!

Eager to test clouds, but hoping seamless switching between Eevee and Cycles will be implemented before final release!

Also, one of my tasks at my day job is sometimes creating renders for a boat brand, so if that real-time ocean with the wake works for smaller boats up close that would be superb! Perhaps it won’t be magazine quality, but if at least we can do in-house and sales renders for it, that would still be interesting!

1 Like

ui wise i think cloud position should be next to sun position, then after working it all out you just have to see the top end

and because elevation seems to change clouds, it would be good idea to have clouds near that setting

1 Like

Thank you for testing the beta! would you please report the exposure issue to our issue tracker?

Improved UI, Cycles fix and more refined cloud control is planned for next version.

1 Like

I’ll try… :slight_smile: Haven’t reported bugs almost at all before, but I’ll see if I can manage to do that this time. :slight_smile: Just need to install the beta again.

Actually, I’m not going to file a report just yet… I’ve been using Blender 3.0a - cycles X version, and that looks like it could be the reason why it’s not working as expected… Tried with 3.0a from the master branch right now after seeing it working in blender 2.93 in Windows 10… I’m going to try In Ubuntu again before I report anything… It would be a little counter-intuitive for you to get bugreports for a cycles-x branch at this point in time I believe…

Edit again:
Ticked off ‘use real world physical values’, like aglyons mentioned below, and it works like a charm. In all versions from 2.93 to 3.0 alpha, plus the cycles-x version… Not going to file a report at this point i think… :slight_smile:

I don’t know what I have wrong here but this is frustrating.

I was using HDRIMaker for my BG and scene lighting and then picked this up because of the new clouds (yes, I’m trying out the beta1.4). I removed the HDRI environment and added the Physical Atmosphere enviro and I ended up with this??

Everything is completely blown out and you can’t see any sun disc anywhere. I’ve checked all my exposure settings both on the film tab and the color management tab. Both are default afaik. I’ve reset my light path bounces to limited GI, 8 bounces max.

My scene scale is set to imperial(feet) not sure if that has any bearing on how it calculates the sun and lighting.

It’s got to be something specific to this scene as I tried it out on a default scene with just a cube and a plane and it worked perfectly. I can’t for the life of me figure out why this is happening.


Ok, so I was going to pull 1.4 and go with the current 1.3x when I noticed that Use Real World Physical Values was checked. I unchecked that and then I started to gain control over things.


1 Like

Actually, I just had the same problem. I had also clicked the realistic values, because that seemed to be the clever thing to do, wanting realistic results and all… xD Oof… Well, thanks for this little tidbit of a workaround… It works here as well now… Even in Cycles-X. :slight_smile:

Oh, right!
Realistic Sun Radiance is off by default. You need to use auto exposure or manually dial it down to -6 to get usable result.

Where is that setting?

I tried dialing it down all the way to the bottom, but It still burns out the sky though… Can you show a screenshot of what that looks like in a scene that you have? Just the default box with the sky using realistic sun radiance and dialled in properly… :slight_smile: Would be nice to have something to compare with…

then it sounds like this issue:

That setting is in the addons tab in the settings window… You just search for physical in there, click the little arrow, and it’s the top one of the three tickboxes there, it’s called ‘Use real world physical values’

Hope that helps.

Ah, not named the same. That is confusing for learning and communication.
Here are my settings; these give me a modicum of control over the addon. And the use of clouds which makes me grin.

1 Like

Maybe… I’m running a GTX980Ti though… :slight_smile: But as long as I can get it working with just unticking that box, I’m fine for now… :slight_smile:

Wow, I just checked out the new update and it looks way better than previous versions! I have one huge problem though. All the previous versions were real-time in eevee, now the performance dropped so much that it’s almost impossible to use in rendered view :frowning: I don’t have a super powerful pc and for example in 1.3.1 with procedural stars I had stable 30 fps, without stars even 60. Now in 1.4.1 beta it doesn’t matter which settings I use, I always have 5 fps, I hope the final version will have a better performance.

Please add cloud rotation. Thanks

1 Like

Yes, 1.4 is much slower due to some extra math. This is why we decided to share ‘beta’ with our clients.
I am also not satisfied with the performance and we will tackle this issue in release candidates.



thinking it would be handy performance toggle to turn off / mute atmo for adjusting clouds

Hi! I am having some trouble with the plugin. I tried to install the beta 1.4.1 version, and although I can turn the atmosphere on, the sun rotation and azimuth do not work. The sliders have no effect on the sun position.

I reverted back to 1.3 and now I have the same problem there as well… Not always, but often.

Any ideas how to fix this please?

This is and interesting add on as community said. Before get this add on I have few question.

  1. Does it have night sky and star and moon?
  2. What about night lighting in EEVEE?

Version 1.3.1 - Blender 2.93.0 - (maybe it’s fixed in 1.4.1 - don’t know - Blender market link is down)
I’ve found a big issue. Material based fog is a great thing, but it’s not working with transparent materials. As you can see in the video - I have planes with textures and alpha but transparent part of the material are “catching” the alpha and when I intensify the effect, problem is very obvious, or when the plane is in big distance…
To avoid that, I can make a workaround to make a mix sahder and plug alpha like a factor (you can see in the video), but when I make another material, addon will refresh/rewire everything automatically and my workarounds are lost…
Issue looks the same in Eevee and Cycles as well.