Physics Engine help

Hello all, got a lot of great advice after posing my last question, now I have another issue I was wondering If I might get some clarity on?

Just really still testing Blender’s capabilities as a game engine, to get to grips with the physics I decided a nice simple bowling sim might be a good place to start, constructed a simple ‘alley’ just a plane extended and with the two (left and right) sides loop cut and extruded up to stop the ball wondering off course, a few simply shaped pins and a uvsphere.

Now there are several issues Im seeing, first is that the pins bounce when the game is started, they fall about an inch or so(if they were scaled in real life) then bounce up a foot or so and just keep bouncing, Ive adjusted the damp, rot damp, restitut options into every setting I can and it keeps happening, If I put damp to full it stops but then doesnt react realistically when hit by the ball, I’ve found a few tutorials where it refers to the restitut value as the value of ‘bounciness’ but found this option to appear to have no direct influence on my pins they just kept bouncing.

Another Issue is the collision detection, the reason they;re falling so far is they fall halfway through the floor before registering a collision, Ive adjust the bounds box through all the options and these only make it worse so they dont even get to the floor before bouncing, Oddly tho the ball doesnt suffer from this just the cylinders I modelled for the pins.(until I started changing bounds options then the ball reacted at the same distance as the pins)

The pins are set as actors, rigid body and the rest are back to their defaults.
The ball is set as actor, rigid body with the addition of a force 20 in the x added to the up arrow key to ‘bowl’ it
The plane used for the alley is actor, static

I just cant stop those damn pins from bouncing! I just want them to start statonary! This doesnt happen with other things., like when following the basics tutorial adding objects and controlling a ball to bump into them, just the cyclinders seem to be made of rubber :frowning:

I’ve had a similar problem where two edited cubes scaled down and put close together just fly apart. I still haven’t figured out how to fix it tho and think it is a general issue with blender. wish I could be of more help

There must be a way to fix it, if you cant place edited objects onto a plane or other edited object and apply physics to them without them reacting like they’re made of rubber or C4 then no one would be able to make any kind of a game out of it, must be something we’re doing wrong, surely some one out there has some idea whats causing it??

I’ve made a really basic example for you:


I would suggest, making sure you scale all of your objects in edit mode.
That might help with the two scaled down cubes flying apart. Another good way to trouble shoot is to turn on physics visualizations. Its in the game menu at the top of the screen. If the bouncy pins problem persists, try setting the mass up a little, or changing the collision margin to something slightly higher. Hope that works.

I know how frustrating something like that can be. It used to happen to me all the time. Good luck and don’t get too discouraged. The BGE is great, it just takes some tweaking to get it to work right.

thanks OTO thats pretty much exactly what I was going for, cant understand why my pins didnt behave like that, maybe your right Joe, could have been that I tend to do most of my scaling in object mode, will try again with scaling in edit mode and using OTO’s example as reference. I guess since the object of all of this was to get to grips with blenders physics engine then its to be expected to have a few teething troubles, compared to the other game engines Ive used (namely Torque and FPSC) blender offers the best of both worlds in respect to ease of use yet powerful features so Im not giving up on it yet!! :slight_smile:

Yeah, your problem (and… andthewicked’s problem, too) probably is that you have the objects scaled up; apply scale on the objects (Ctrl-A). Like Joe_Stevens said, turning on Physics Visualization is extremely helpful for knowing what the problem is in terms of collisions and motion.

Might be an idea for someone to add that into the blender basics tutorials, theres a section on scaling early on might be worth mentioning it there, so people are aware of it from the start if thats whats causing the problem as for the physics visualisations thats a fair point, I’ll keep that in mind for future models, now just have to get my head around textures…o.0 no where near as simple as the milkshape 3d method Im familiar with!

Textures are pretty simple - for non-GLSL, apply the UV-map of the mesh to the image and it should show. For more lighting, use a material and set the image to soft or hard (?) light in the blending mode for the texture. For GLSL mode, do that same process, but you don’t have to do soft or hard lighting mode for the lighting to show up correctly on the mesh.