Picture map disappears from UV-Editor

Hi

I have a problem using the UV-editor. I have used it often (and successfully up to now!), but now all of a sudden it drives me crazy. What happens is this:

  1. I open the picture I want to map (its a jpg) in the UV-editor. It’s displayed correctly.
  2. I select my mesh and change to edit-mode
  3. I select the faces to unwrap and “u->project from view”
  4. The selected faces are displayed in the UV-editor-window, however the picture disappears. It’s gone, and all that’s left is the default grey square with the grid.
  5. I try to re-load the picture, and blender does pretend to do something, but the picture stays invisible.
  6. I repeated the steps above multiple times, even closed blender in between the tries. I deleted all UV-Maps for the mesh and started all over, with the same result.
  7. I can open the picture, either by image->open or selecting it from the dropdown, but it will only show up when no mesh is selected. As soon as I try to unwrap any surfaces the picture vanishes again.
  8. I yell at the PC, blender, stupid programmers, stupid me, stupid universe and moan my miserable fate.
  9. I call for help on blender-artists :wink:

To fix this I normally:
1: Goto object mode
2: Load the picture
3: Goto edit mode, select all points and even if the picture vanishes (u > unwrap)
4: Then goto the view you want and do what you need to do.

Well, at least I’m not the only one who ever encountered this problem. Thanx for your suggestion!
However, the whole point in UV-mapping is precision, and the only place where I can really precision-place a complex UV-map onto a complex geometry is the UV-editor. I know I can theoretically move the surfaces around in the editor, and watch the update in a 3d-window tuned to the right perspective and to show uv-maps. But firstly the viewport UV is lowres, and secondly the mesh is really complex. There ought to be a way to make the UV-editor work the way it should do!

make the UV-editor work the way it should do

I don’t think it is a problem with the UV editor.

In older version of blender there was a face select mode and it was clearer how things are organized.
Every single face has its own pointer to an image.
Every time you selected a face this structure is read to determine which image is assigned to this face. Yes, you can assign a different image to every single face. So my guess would be that the image in the UV editor is disappearing when you select a face that has no valid image assigned to it yet.

The work flow in face select mode was:
-Select face(s) in 3D view
-Use the image combo in the UV editor to assign image to faces

This is how it works in edit mode now too but not so obvious.

To make it a little more confusing there is another way linking a face to an image:
The face holds a material index which points to material that contains a image texture.
But the only relation this has to UV is that the texture can use UVs for mapping input.

This is exactly what I try to do: I use the UV-Map to place a material-texture. But that’s just for info…

Yes, I can assign a picture to each single face. That’s not the point. I’m quite sure this is a bug of the UV-Editor. If I have a face (unwrapped) in the UV-Editor I should be able to load a picture to assign to that face. However I can no longer load any picture, no matter whether it’s a new one or one already in the drop-down-list of the editor.

In the meantime I have loaded an older version of the mesh to a new scene and done the UV-Mapping again. It worked like it should have, although I used exactly the same procedure. I tried to replicate the problem and after a few tries (doint the same thing) I managed to do so. Open the attached .blend and go to edit-mode. Try to assign sample.jpg (packed into file) to the selected face.

Attachments

UV-Bug.blend (180 KB)

It is a problem with Blender all you have to do is select a face on the mesh and the texture will re-appear.

I don’t yet know the ‘proper way’ to do this either but a workaround is to go to Object Mode which should allow you to load the image into the UV Editor. Then click the lock button (tack icon). This should keep the image you selected in view when you go back to Edit Mode and select the face you want to work on.

1 Like

@atom: I know it works in this case with the testfile, but back in the original situation the problem was much more persistent :o. Deselecting and reselecting the face (or any other face) did not help under the original conditions. Also deleting the UV-map and starting all over will solve the problem in the testfile, but didn’t work under the original circumstances. It seems I have only replicated a somehow “weak” version of the bug.

@jrboddie1: Excellent! This might just work even with the real thing, when I encounter it again! Thank you so much, buddy! :smiley:

I turned on textured display in 3D view immediately after loading your file and noticed the image is already assigned to the face. Also the UV are scaled properly. But no image in UV edit displayed.
Turning on face select in UV editor and selecting the face in UV editor makes the image pop up.
Well it seems some times the to windows get out of sync.
Looks like dropping the face select mode in 3d window left some glitches.
Could you please test with your borked file if selecting the face in UV editor heals missing images?