Pie Menu Editor 1.15.20

commercial
add-ons
(roaoao) #2010

Try this in Property tab:

C.object.show_wire
1 Like

(roaoao) #2011

Yes, I’ve updated the example. It will be available in the next version.
Download and copy command_context_sensitive_menu.py file to pie_menu_editor/scripts folder and import context_sensitive_menu.json file.

To add more context sensitive menus you need to name your sub-menus with some prefix/suffix. Eg:
CSM2: None Object, CSM2: Mesh, CSM2: Any Object
And update the code for the context sensitive menu (Command tab):

execute_script("scripts/command_context_sensitive_menu.py", prefix="CSM2: ")
0 Likes

(Nomo) #2012

Worked beautifully! Thank you.

0 Likes

(cartoon shaman) #2013

that doesn’t affect the margin. I think is something predeterminated in code. Thks

0 Likes

(roaoao) #2014

Pie Menu Editor 1.15.17


What’s New:

  • Blender 2.8 Beta Support
  • Bug Fixes

How to Update:

  • Backup your pie menus using Export button (optional).
  • Open User Preferences.
  • Go to the Add-Ons tab.
  • Click Install Add-on from File button, navigate to the file you downloaded and install it.
  • Restart Blender.
3 Likes

(radi0n) #2015

Hey,

i want to create top toolbar in shader editor.
When i try to add node (for example noise texture) shift+a right click on noise texture and Pie Menu Editor, choose Top Toolbar and button is inactive.
In PME preferences in Top Toolbar button have command:

bpy.ops.node.add_node(type=‘ShaderNodeTexNoise’, use_transform=True)

0 Likes

(roaoao) #2016

Hi, @Pinhead
This tool requires Node Editor Area to be active.

Download and copy this patch to scripts/addons/pie_menu_editor folder and restart Blender.
The patch adds focus_area() function which will be useful for your toolbar.

Now you have 2 ways to fix the tool:

  1. You can create a new macro (download) and use it in your toolbar buttons (Command tab):
open_menu('Add Node Macro', node_type="ShaderNodeTexNoise")
  1. Or just use this code in toolbar buttons (Command tab):
node_type = "ShaderNodeTexNoise"; focus_area('NODE_EDITOR', center=False); bpy.ops.pme.timeout(cmd="bpy.ops.node.add_node(override_context(area='NODE_EDITOR', region='WINDOW'), type='%s', use_transform=False); bpy.ops.node.translate_attach_remove_on_cancel(override_context(area='NODE_EDITOR', region='WINDOW'), 'INVOKE_DEFAULT', True)" % node_type)
2 Likes

(ssllav) #2017

Hello.
There’s a little problem.
After installation 15.17 on 2.79 last, menu in the settings is displayed at the bottom of the User preferences window.

After many removals and reinstallations of all Addons, back to old version 1.14 which works without complaints.
Maybe it’s the Blender. Shouldn’t be chasing the latest version. ((

0 Likes

(roaoao) #2018

Hi, @ssllav
What do you mean by 2.79 last ? Where I can find it?
I’ve tried to download and install Blender from this page and it works.

0 Likes

(ssllav) #2019

Yes, I install from there.
It’s weird, but menu again displayed at the bottom. At the same time them was installed from scratch + pme only… after system cleaning.

0 Likes

(roaoao) #2020

Thanks, will try to find a solution.

0 Likes

(ssllav) #2021

Could you reproduce this issue? Or maybe i can do something for help you to find what’s wrong? It is not critical, but it is not convenient. I’m not even sure, what the problem is.

0 Likes

(roaoao) #2022

Yep, it’s random but it happens.
Please try to copy this file to scripts/addons/pie_menu_editor/ folder and restart Blender.

1 Like

(ssllav) #2023

Nothing.
I put the file in
AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\pie_menu_editor
But nothing happened.

Suggesting that maybe the process of install changed. I tried to put it in the archive with the addon, replacing the original. And install from User Pref … Nothing.

0 Likes

(roaoao) #2024

Updated the file. Please try again.

0 Likes

(ssllav) #2025

It`s work. Awesome. Thank you very much!

0 Likes

(ANimator120) #2026

Hello, incredible add-on. I have been struggling with one issue though. I would like to create context sensitive commands in the Node Editor. For example, a command which would allow me to change the name of a currently selected node. Right now it seems like I must designate the node tree and specific node name if I want to make changes to the node, I want something that will allow me to change the properties of any given node. How would I do this with Pie Editor?

0 Likes

(iceythe) #2027

Add C.active_node.name to property box.

I recommend Context Browser 1.2.1 from roaoao if you’re struggling with finding context members. Nodes have a special context which isn’t accessible from the interactive console.

0 Likes

(radi0n) #2028

Thank You roaoao! Works great!
It is possible to make toolbars more wider?

0 Likes

(roaoao) #2029

You can change toolbar size in add-on preferences (video).

0 Likes