Pie Menu Editor 1.16.4

Thank you very much, this is very cool. :star_struck:
Gone to smoke manuals.

Is it possible to use sub panels in a panel group? https://docs.blender.org/api/current/bpy.types.Panel.html#bpy.types.Panel.bl_parent_id

I’m having trouble even putting a sub panel right now from a different addon. Though it could be an issue with that addon perhaps. The first sub panel comes over fine but the second just shows up empty in the panel group. This is how the sub panels look in an addon.

This si how i’ve set up my panel group: image

This is it not showing up in the panel group:

Also is there a way to hide/resize the panel headers? They can take up quite some room.

No, but I’m working on this feature for the next version.

Interesting question. I’ll try to implement some feature for this.

1 Like

Hi @roaoao, Is it possible to add Disable by Tag(s) to this Property?

bpy.ops.pme.pm_enable_by_tag(enable=props(“Toggle Select Linked”), tag=“Select Linked”)


Basically, I’m trying to enable a menu and disable multiple other menus by clicking on 1 Toggle Button/ Property.

Hi @anphung,
Yes, use this code as getter:

tag = "Select Linked"; has_enabled_menus = len([m for m in prefs().pie_menus if tag in m.tag and m.enabled]) > 0; return has_enabled_menus


bpy.ops.pme.pm_enable_by_tag(tag="Select Linked", enable=value)

Another way to create this button is to use Custom tab with this code. No need to add a new Property in this case.

tag = "Select Linked"; has_enabled_menus = len([m for m in prefs().pie_menus if tag in m.tag and m.enabled]) > 0; operator(L, "pme.pm_enable_by_tag", text=tag, icon='CHECKBOX_HLT' if has_enabled_menus else 'CHECKBOX_DEHLT',  depress=has_enabled_menus, enable=not has_enabled_menus, tag=tag)

This post is just to say (again) a big THANK YOU @roaoao. Just that.

Hello. Is there any code that will temporarily disable the display of axes during transformation?


Hi Roaoao,

I edit my question again… i have got everything to work but if you could check this out and if there is an easy fix for this would be great… If not it’s no big deal


This is the default behavior the size of the popup expanded in a pie is calculated automatically from the content. I would like also that this size setting apply to expanded popup…

Btw @roaoao did you think it is possible to have this feature for better efficiency?

Hey man… thanks… i just edited my post as i found out it’s only truncating the last character(s), by putting a few spaces after i have gotten it to reveal the whole text but adds a couple of dots which would be nice to get rid of

Here with no spaces after… ( 4 is needed )

EDIT: @StroBlend: Maybe it’s already in there? You mean that the pop-up should be the same width as the first “Pie-button” ? My pop-up is the same size as the first button… I got around the truncating by adding a blank “button” on top, inserted a lot of gibberish dots to the width i wanted and set the button to Invisible… I’m guessing the pop-up width is what you set in “Settings” for Pop-up and Regular menu dialogs

… and perhaps use the “Fixed size” at each button


No, I can’t fix this in the add-on. But I’ll add an option to add extra width for expanded popups in pies in the next version.


Thanks it will be a great addition to have uniform sized popups.

Not sure you got it right but for the question I was referring to the ability to add popups next to pie buttons to increase the efficiency and organisation. Do you think it would be possible?

I think there’s a bug with 2.82 @roaoao. Changing, Removing, or Disabling a menu’s hotkey doesn’t delete the hotkey in Blender’s Keymap editor. Restarting Blender doesn’t fix it. Could you look into it?

1 Like

No, afaik, this is not possible.

1 Like

Hi @anphung,
it works for me. Please export and pm me your menus. Will try to reproduce the bug with them.

1 Like

Well… I tried again today. And it’s fine. Don’t know what that was about. Sorry about that.

your not alone, PME on 2.8x has so frustrating

@roaoao Could I borrow a moment of your time ?
I am trying to assign hotkey 1, 2, 3 to switch between vert edge face selection in UV editor both in UV sync selection on and off.
while UV sync selection is off, I use command
bpy.context.scene.tool_settings.uv_select_mode = ‘VERTEX’ etc to switch
and while UV sync selection is on, I use command
bpy.context.tool_settings.mesh_select_mode = (True, False, False) etc to switch between vert edge and face.
but with the condition
bpy.context.scene.tool_settings.use_uv_select_sync = False
I can not piece them together to work. I got invalid syntax.

bpy.context.scene.tool_settings.uv_select_mode = ‘VERTEX’ if bpy.context.scene.tool_settings.use_uv_select_sync = False
else bpy.context.tool_settings.mesh_select_mode = (True, False, False)

currently I use 1,2,3 while uv sync selection is off and 4,5,6 while uv sync selection is on to switch between vert edge and face selection.

You can try using a macro. It works for me. No condition needed.

1 Like

sweet! works like a charm!
thanks a lot!!!

1 Like