Pie Menu Editor 1.18.6

Thanks and sorry, i think im not getting it… could you elaborate that a little more please?

I create the toolbars following this tutorial:

1 Like

That video shows another way of making a toolbar. It’s using the User Preferences editor, so the Local View button won’t work.
You have to put the button in the 3D View.
To do that, you need to create a Popup Dialog, add your button (click on “Button”, Edit item, click on the 3-line button on the right, Operator, type in “local view”, OK).
Then create a Panel Group, set “Panel space” = 3D View, “Panel region” = Header.
Then click on Add Panel button, choose Popup Dialog, then type in the name of the Popup Dialog created earlier.

Menus made in the GIF:
3DViewHeaderToolbar.json (731 Bytes)

Got it working. You are a god Sir, thank you a lot for taking the time to help me…!!!

Great work updating the addon for 2.8 @roaoao ! I really love it :smiley:
On my main Linux computer it has been working perfectly for me but lately on my 64bit WIndows 10 Laptop I had trouble to get it working properly.
The usual case is that don’t get the interface of the editor, even with the fixed files that you provided.
But with for example the latest builds from today I get this once I try to enable the addon: https://hastebin.com/uzamiyakec.sql

I hope you can help me out. Getting my menus back soon for Windows would be a blessing :slight_smile:

Hi, please send me all messages from terminal.
And check python version in Blender’s console:

import sys
sys.version

This is everything from blenders system console from opening blender, loading factory settings and enabling the addon: https://hastebin.com/iheforifoc.sql
I can’t access the python console though. The editor is always empty and gives me this error repeatedly when I hover over it :confused:
https://hastebin.com/zahusofuka.sql

Try to disable all addons or reinstall Blender (backup and delete config folder) and check python version in console using this code:

import sys
sys.version

The issue was found. There was a random types.py file in the addons folder that was not supposed to be there. This caused some problems throughout Blender somehow.
Deleting the config folder als helped a lot!

Everything is fixed now and is working perfectly. Thanks :slight_smile:

glad to see that you are using this addon julien ,

its very useful, :slight_smile:

1 Like

One of my favourite addons for quite some time :smiley:

2 Likes

Hi roaoao. Popup Area is crashing blender, and Side Area is giving error in this build. I know it’s not an official build. But it would be amazing if you could help me fix this. Unlike the daily build and 2.8, it’s the only build with Weighted Normals modifier and Bevel Shader that’s stable and doesn’t change. So your fix would be a one-time thing.
Thank you in advance.

Hello roaoao,

I’m ready to enter in 2.8 dimension thanks to your latest upgrades :grinning:. But many of the old buttons seems broken, or when trying to add new ones appears the message “can’t add this widget” most of the tryings. What we might to expect from 2.8 the PME users? :thinking:

Hi, @anphung
Where I can find sources for this custom build?

Build: http://cgstrive.com/blender/Blender2_79_6_wn_cgs.rar
Source: http://cgstrive.com/blend/blender_WN_modifier_hacks_source.rar

Check Python API changes.

Will try to fix this in Blender 2.8 beta.

Thanks for the response, there’s a lot of expectation with 2.8 build, and is hard to image to use it without your add-on working fine. You have created a deep depency!!

Hi rao rao again question
im creating a macro
after i rotate the object ( modal ) i want to automatically press enter is it possible?

Do you want to run some operator assigned to Enter hotkey?

hi there!
Im testing this with Blender 2.8. I love the plugin… but still a noob with 0 coding skills.

What im trying is to make buttons to put on my 3dview left side panel. But im having the following troubles:
If i try to put a check button (on/off), like the show grid one (show grid/hide grid), the code is ok but the button just… vanishes… its not there (in the toolbar). There is no way to see it or click it.

Any idea please? Thanks!!

How do you have two properties assigned to a single item?