Pie Menu Editor 1.18.6

Ok finally i solved my problem with the use of Stack Keys. I doubt there is a way to show different background color for the button depending in which state it is… but i can live without that :slight_smile:

You guys that are trying this out in 2.8…what build of blender are you using. 1.15.6 doesn’t work with anything I have downloaded from the October 15th nightly build up to last night’s build for windows 64 bit.

I’m still on the Oct 10th build.
Just wait for the beta in 2,3 weeks. The new API should be done by then, roaoao can then release a new version.

Its working fine for me in latest 2.8 build version.

One more questions roaoao. How would you move between area types and space context in UV/Image editor? Trying to make a pie so I can go from any view to UVEdit even it View image was previously selected. For now I can only move to UV/Image editor and see what ever was already visible.

This code works for me in Property tab:

bpy.context.space_data.overlay.show_floor

Check this example.

Looks like API for switching area types was changed. Try this in Command tab:

bpy.context.area.ui_type = 'IMAGE_EDITOR'; bpy.context.space_data.mode = 'UV'

There’s a hotfix in this thread which hasn’t been pushed to the PME download. Did you try this?

Thanks both worked perfectly. :slight_smile:

Can we export several elements in order to export more than one? Using shift it won’t let me select more.

Yes, you can export enabled items.

Or assign a Tag to the ones you want to export and Export by Tag

I see the thing is that I have lots of disabled items I don’t want to export and doing it that way will be a mess. Didn’t know about the tagging thing will check that out now.

Thanks checking that now.

Those tags are amazing and I totally ignored them for years! :smiley: Thanks again man.

Tags are pretty great. You can use them with Property items to toggle on off different items.
Examples: Changing what the hotkey Tweak LMB does
From Box Select to Slide & merge vertex:

From Box Select to Translate

Those are some Ninja Tweaks!. Will check that asap.

1.15.6 not working for me in the last 2.80…
Working in the 2.80 i downloaded a month ago

Or is it only me?

Yep, it’s not working again.
Will release the fix today.
But please keep in mind that all add-ons can be broken at any time during the Blender 2.8 Alpha.