PitchiPoy rigging, minor issue

Hey all!
So, just got the newest version of blender with the pitchipoy rig (automatic face rig, omg!), and I was going along and rigging just fine, armor pieces, clothes, all that. But then two pieces seemed to be giving me issues, and not rigging like anything else.

The name of the parts in the included file are “Breast plate” and “Eyelashes”.

Now, i’ve tried rigging it according to two different videos. This one, http://tinyurl.com/nkaam63 hasn’t been working with pitchipoy at all. The best solution to this problem is getting this method to work, since I like it better. The second video is this one, http://tinyurl.com/nlheks3 which has worked fine for everything except those two parts.

File: Willow Mk. 13 test4 .blend (7.16 MB)

Any help is appreciated! Thanks all!

Shameless three day bump.

All of your meshes have some degree of un-applied location, rotation or scale. To apply the loc,rot and scale, select a mesh, CTRL-A then pick a transform (loc, rot, or scale). Also, your belt and skirt items have flipped normals. Select all of the vertices in edit mode, in the UV/Shading tools tab find recalculate normals. You will see the item go from a greyish color to white.

If you plan on using subdivision on any of the mesh items, you will have problems. The subdivision modifier does not work well with tris. Retopologize your meshes to have quad faces.

I am surprised that you have made it this far with those mesh issues. The reason your breastplate and eyelashes are not moving with the armature is, there is not armature modifier on those meshes.

Good luck!

Doesn’t the armature modifier show up when it’s assigned to a bone? That’s the problem. When assigned to any bone(s), they still won’t move, even with an armature modifier.

You haven’t applied the ‘mirror’ modifier. That has cocked up your entire rig. You need to clearout all your shapekeys, unlink the ‘multiple datablocks’ in your meshes, apply the mirror modifier and start rebuilding it again. This is why you’re supposed to wait until you’re completely sure you’re finished before you commence starting a rig. Your actual rig seems complicated and the mesh itself needs a lot of work as well, as danpro has pointed out.

Then why is the problem only the eyelashes and breastplate? Everything else works perfectly fine with no problems. This isn’t a huge something wrong with the model/rig. It’s just two parts. The rig isn’t mine. It came with the newest update in blender.

I do appreciate the tips, though. I’ll definetely update the model, but I still don’t think that the model itself is the problem in rigging.

I don’t know. You got lucky. Let’s fix this anyways.

Try this: Select all of your mesh items (Hot key A in the 3d view). Everything should be orange or yellowish in color. Type ALT-G, ALT-S and ALT-R.

All of your meshes will get blown up by different degrees. I should not need to tell you this is a bad thing.

Type CTRL-Z to undo this and get you meshes back into the proper place. Do you see what I mean now?

Follow my instructions above to fix this. Then we will go from there.

It all starts with the model. It must be error free before rigging/skinning is attempted or you will be wasting time and certainly need to redo things.

Good luck!

Alright, so I did what Dan told me to do:

  1. Apply loc, rot, scale. Check.
  2. Fix normals on belt and skirt. Check.
  3. Retopologize. See below.
  4. Apply mirror modifier. See below.

Alright, had two issues. First, retopo.
I have no idea what that is, and a google search just made me more confused. Am I making a second mesh? Is there a button for it?

Second, applying the mirror modifier. It applied to all except the breastplate and character model, giving me the error, “Modifiers cannot be applied to multi-user data”. Um…what? Multi-user data?

The other things have fixed a few tiny things that have come up earlier, so lots of thanks for that, fellas. I’m new to this, so I really appreciate the tips for modelling.

EDIT: Found a solution to the multi user data thing with a quick google search; select object, then U>object & data. Worked fine, mirror is now applied to everything. Just need help with the retopo.

Four day bump


I didn’t check your file, but retopo is in fact recreating a clean mesh or in your case, I think, it could be cleaning your mesh. So, there isn’t a button for it.

Hope it helps.