Pixar RenderMan for Blender!

@Indy_logic: My scene is rendering inside a UV Image editor and not in the external renderer do you know why ?

LOL I am on Mac and it does not work…

I’m on windows and it works when “Display Driver” is set to automatic (it returns the image to the image editor) but it doesnt work when set to “it”. In the tool tips for the “it” option it says “Must have RMS installed”… don’t know yet what’s RMS.


The problem seems to be that “it” isn’t installed with the “stand alone” installation. Found this in Renderman’s docs:

“Note: “it” is installed as part of the RenderMan Studio product, and is not part of the RenderMan Pro Server installation”

So it seems “RMS” stands for “RenderMan Studio”

Seems to be working here. You need to run the installer first before activating the addon, it grabs some stuff from your prman install during the activation function, apparently. The PxrDisney node is glorious. I too have gotten a bit sick of figuring out the weirdness of fresnel in Cycles. The UI for the texture node is kinda awkward though, why isn’t there a file picker on the node?

@pitiwazou Did you try it with the blender terminal open? Might be a more descriptive error message in there.

@dario.baldi You need to open the it.exe (in the RenderManStudio-20.0-maya2014) application in order to launch a render with the IT Display Driver. It’s an external Frame Buffer. As soon as you launch it blender will be able to render to it.

The Hair shader make me crash :frowning:

Is working fine here, I’m on windows too, with the latest build of Blender.

How do I control the GI settings…? I’m kinda lost in all the render settings hehe.

What are you looking to set? Most of the settings are pretty similar to what Cycles has in the sampling/light paths panels. Make sure you’re using the “path” or “vcm” integrators, those the raytrace GI ones. I think “default” gives you the old REYES one? I might be wrong on that, though.

Thanks, it’s more or less what I said on my edit. I don’t have RenderMan Studio because I don’t have Maya: the installer only installs RenderMan Server. I tried re-installing renderman but I don’t get the option of installing RMS without having Maya.

When the installer comes up and says you don’t have Maya installed you need to click ‘ok’ then check the box that says show all at the bottom and then select Maya 2014

Dude, you’re the man! :smiley: Many thanks

I just noticed something, the render changes drastically when I change the display to IT, here’s a comparison:

When set to Automatic it appears as if Blender already did some sort of color management to the image…
Also, it renders faster when set to IT.
Is that an expected behavior? Or is it because of the exporter?

I definitely have to study this more, I like it very much so far :slight_smile:

For me it works, it was my user name with an “é”.

Can you upload a blend file? I’m getting black renders with transparent BG… also not sure what IT is…

trying to install the blender addon…I have this error

File “C:\Users\XXXXXXXXX\AppData\Roaming\Blender Foundation\Blender\2.75\scripts\addons\PRMan_init_.py”, line 39, in <module>
from . import engine
File “C:\Users\XXXXXXXXX\AppData\Roaming\Blender Foundation\Blender\2.75\scripts\addons\PRMan\engine.py”, line 39, in <module>
from .util import bpy_newer_257
File “C:\Users\XXXXXXXXX\AppData\Roaming\Blender Foundation\Blender\2.75\scripts\addons\PRMan\util.py”, line 33, in <module>
from extensions_framework import util as efutil
File “C:\Users\XXXXXXXXX\AppData\Roaming\Blender Foundation\Blender\2.75\scripts\addons\extensions_framework_init_.py”, line 31, in <module>
from …extensions_framework.ui import EF_OT_msg
ValueError: attempted relative import beyond top-level package

For people that installs without problems…how did you do?


Has anyone gotten it to work on Linux? I’m getting the same error:

Error: PRMan: Exited


Does it works with animation for you, it locks at frame 01 for me with the it ?

Hi everyone, I’m not involved in the development in any way. Just posted the news. Remember it’s still beta so there are going to be bugs.

Please remember to go to the official Pixar forum to get actual support and report any bugs. :slight_smile:

At the bottom of the render panel you’ll see an option for Display driver. Change that to “IT”. I found that I needed to launch IT manually to get it to work for me so if it still gives you problems, try that.

Also, there seems to be issues with the installer not setting up you PRMANTREE environment variable. You might get it working if you set that.

Yeah, no non-standard characters in your user names. :wink:

COOL! It’s great to see how Cycles isn’t really that far off when compared. Although, like with Arnold, I’d like to see how things go when you start messing with DOF, Motion blur, displacement, hair and volumetrics, etc.