Pixel art Transparency Glitch.[Solved:Use Clip Alpha, not Z]

I didn’t really want to let on that I had this in the works just yet, but I’m having a graphical error I can’t seem to solve. The best way I can describe it, is that the character is being rendered in the wrong depth relative to the environment. Let me show you:

This error seems to arise from the Z-Transparency on the environment material, since as you see when I turn it off, the character is rendered appropriately.

I’m new to pixel art game design, but I’ve noticed that this community has several. (I’m using Solarlune’s animation script after all.) I’m sure someone else has seen and solved this before. Please help me!

Better use clip alpha mode.

  • you do not have partial transparency
  • it is much more efficient
  • it does not have the sorting problems as the render methods for semi-transparency

The problem you have is due to the z-Sorting. You need to enable enable Alpha sort. The object centers need to be in the middle of the objects. faces should not cross each other.
As stated earlier better use clip alpha.

Thanks so much Monster, as usual your advice is comprehensive and accurate; worked like a charm!