Pixelated/Noisy Textures in Cycles

Okay, so here’s my problem. I was testing out making a shader in Cycles and I keep getting this graininess. particularly in the light reflections. I’ve already bumped up my render samples to 100, and have enabled ‘no caustic’. It’s helped a little, but I still get this. Does anyone know why?

The red bits are all I’ve really done anything with. All of the white is just the default material.

Running Blender 2.69 in LinuxMint 17

Try enabling “multiple importance sampling” for the light source. And btw: 100 samples is still very much on the low side…:wink: