Pixelated Shadow Edges

Hi All,

I’m sure this is a very easy problem, but I have no clue. I’ve searched for the answer but I guess my search critira are wrong.

I am creating an animation that uses a spot light with the buf.shadow property turned on.

The problem I am having is that shadows are all pixelated along the edges. Nothing else in the image is this way, what is causing this with my shadows?



do you have OSA turned on?

Yes. The OSA button is on.

That should make the image render at least 5 passes before it is finised correct?


you won’t see it render more than once with osa on…are you thinking of the mblur (motion blur) button which will render it X (determined by osa setting) times.
Set your osa filter type to gaussian (in the render panel of F10 window…there’s a combo box type control inbetween “fields” and “Border” buttons.

Yeah I guess I am thinking of MBLUR, as to the multipass reneder. I did have the OSA button on. I do have it set to Gauss, with a value of 1.00.

And still very pixelated shadow edges. :frowning:


Increase shadow buffer size and/or number of samples…

That seems to have been the problem. :stuck_out_tongue:

Thanks to all.


The thumb of rule though is that when you increase the shadow buffer above 2048, you’d be better off by raytracing the scene. That is what Jeremy Birnn said anyway in his book.