Pixels

I wanted to make a guy have the same-ish look as Minecraft, but even with minimaps off it doesn’t work right. The picture will explain. I want the texture to be sharp and blender is making it kind of blurred. :confused:

Attachments


I don’t think it’s Blender - it’s probably your graphics card. It might have anti-aliasing on or something, because I’ve gotten pixel-perfect art in the BGE with no mip-maps.



Agreed. Turn off anti-aliasing.

It didn’t do anything. O.o

Try changing the anisotropic filtering, maybe? Also try messing around with the draw settings in the User Preferences panel in Blender. It is possible to get pixel-perfect graphics, though.

What is the Draw setting under? Would it be pixel-perfect in .exe form?

It should be pixel-perfect in Blender - that’s where I took my screenshot from. The draw settings are in the User Preferences, under the ‘System’ tab.


I can’t find it. :\ I am using 2.49b. Does that not have it? Where is it in the photo?

That Mip-map setting should be it. It looks like it’s working, but you know what I’m thinking? It’s possible that you’re using a poor file format for the texture (like jpeg). Try png files - those seem easy to get pixel-perfect.