Plane Doesn’t Fit Curve Properly

Hi, I am trying to create a roller coaster effect. So I vertex parented the cubes to a plane, but the problem is when I select the plane and add a “Curve Modifier” the plane doesn’t properly fit to the curve.

Please tell me why this is so difficult to set up properly in Blender.

Attachments


Have you tried to do Object -> Apply -> Rotation&Scale (or CTRL+A -> Rotation&Scale) for both the model and the curve when in Object Mode (best do it before adding the curve modifer to the model) ?
I had a problem similar at some point, and applying rotation&scale in object mode for both model and curve fixed it.

Thanks Sanctuary, I started from scratch and unparented everything, then reset the location, rotation and scale for every object (and the curve) then vertex parented the cubes to the plane again. Then applied the Curve modifier after but Unfortunately the results were the same. :frowning:

Can you upload that blend ?

Here it is. Just select the plane and add a “Curve" Modifier to it to see the problem.

http://www.pasteall.org/blend/12552

Have you tried to rotate the plane 90 degree so it points toward the X axis instead of the Y axis ?
It looks like if i do that before adding the Curve modifier, the plane is now correctly placed on the circle path

Fixed it.
I think you need 2 parents: one for the object container and one for the object container to slide on.
http://speedmodeling.org/smcfiles/amdbcg_rollercoaster.blend

So are you rotating the plane only (after subdividing it) and leaving the cars in the same position?

Great job AMDBCG, but I can’t figure out how you set it up. I see you have the 2 cars on layer 2 but I don’t see a plane anywhere in your file but a hook. I don’t understand how you set this up. Can you please explain. :slight_smile: Thanks.

Also, have you found this can’t be done properly using a plane object? Were you not able to get it working from my file? Thanks.

Yes, just the plane, the cars being parented to that plane will automatically rotate with it.
http://i.imgur.com/Gd4Xp.jpg

into
http://i.imgur.com/y7io4.jpg

lead after adding the curve modifier to this :
http://i.imgur.com/6zFlO.jpg

Awesome thanks for explaining Sancturary. :slight_smile: Must be a bug in Blender because this step (rotating the plane) shouldn’t be necessary. :slight_smile:

BTW are you familiar with the method AMDBCG is using with “Hooks”? I would like to try this method but don’t know how he set it up.

Yes it’s possible this is a bug, i don’t know if it has been fixed, but there was already some problem since 2.4x and possibly more regarding appareance of "knots" in a curve depending on the curve orientation.
So this being a related bug (as it’s again something linked to the orientation) wouldn’t be surprised

I’m not familiar at all with the hook modifier, never used it, will have to look into his method to see how it works.

it’s an array modifier, not hooks. I’m not sure how to explain it.
maybe this will help?
http://wiki.blender.org/index.php/Doc:2.4/Manual/Modifiers/Generate/Array

I did not go off of your basis because I saw the array modifier as an easier solution. Perhaps you might dissect the blend file a bit and look at the documentation wiki some more.
good luck.