Plane with image/alpha casting square shadows (2.5 new build)

Can anyone help me figure out why my plane that has a PNG mapped to it, with a alpha channel, is still casting square shadows (not the shape of the image). I’ve attached the blend file here.

I imported the image using the “Image as Planes” script. I’m using a build from from today. I’ve tried many different settings and light setups. I’ve tried checking “Receive Transparent” in the material for the plane.

I know in 2.49, you use the TransShadow button to achieve this. But no matter what settings I try, I can’t get it to work.

Anyone have any tips? It would be greatly appreciated!


ImagePlaneAnimation.blend (770 KB)

The object receiving the shadows has to have the ‘Receive Transparent’ button on. In your case this would be the object named ‘Plane’. So add a material for it and click on the ‘Receive Transparent’ button in the shadows panel.

Ha! Thanks JDep, I feel like such an idiot right now!