Planes not showing up in the render

Hello,

I am trying to render my first scene in Blender and I think I’ve set all render layers properly and such but still not everything is showing up when I hit F12. The screenshot should provide enough information.

In the upperleft my scene in object mode, upperright you see the rendered view port and down below you see the outcome that I get when I hit F12, which I presume is the final render btn.

http://www.upload.ee/image/3076032/IMG_16022013_010914.png

Edit I checked “Emission” in the right panel and now at least the reflections are showing up.

If you look in the Outliner Window in the top right corner of your screenshot you have some objects with renderability turned OFF (camera icon). Mouse click on the greyed out icon to enable renderability

Haha wow that was stupid of me, thanks a lot Richard!