Planes with transparent textures not sorting correctly with particles

Hello, I’m a complete Blender newb, but decided to get my feet wet on a relatively simple project.

Basically, I’ve got a flat plane representing a hand-drawn map (think Lord of the Rings opening), and some small angled planes sitting on top of it, which I’ve transparently textured with some simple tree and landmark images, using .PNGs

But now I’ve decided to add some simple particle systems to give the map a little atmosphere here and there. Unfortunately the particles are not sorting with the planes that have transparency on them. The particles are always rendered BEHIND the planes. I’m using Blender Internal for this project.

Any ideas? Many thanks.

After fiddling my heart out, changing the Transparency setting (in the properties/materials tab) to “Raytrace” rather than “ZTransparency” fixed this issue for me.

The transparency no longer works in Viewport shading, but I can live with that.