Planet Exploding Tut Problem

Hi, I’m following a tutorial on a planet exploding tut:
at about 6.31 he explains that you need to join both spheres (I think it means both spheres) but although I’ve done as he says, “shift and right click one of the objects”
then the ‘join’ button becoimes available, so then you click it - only when I click the join button Blender just says “No mesh data to join!”

Now the first time it didn’t work I tried selecting one of the objects in the scene list on the right and then clicking on join - but I still get the same message, and I can’t select more than 1 object at the same time in the scene list…

And in anycase, how on earth can you tell if it has worked, and things are joined?

Help? What do I do?

(I’m using blender 2.69)

Right click first object, it’ll highlight orange. Hold shift and right click second object which should also then highlight. Press join.

Thank you for the help,

However, it doesn’t highlight orange, it has a tiny orange dot in the centre of each shard of the planet. Is this the same thing?
(I did something when the entire thing was selected and must have thus ‘dropped’ it - it became deselected)

After a lot of trial and error, I’ve managed to select some different shards that seemed to be not selected before, and now when clicking ‘join’ I get all the shards (seemingly) melded together, but there’s still one other object in the scene list - and that isn’t a shard in that it’s not called ‘sphere_cell.074’ but just ‘sphere’.

My question now is therefore, don’t I need to join this sphere with the shards?
But when I try I just get this error message:
‘Active object is not a selected mesh’ - what’s going on?

No, it’s okay. I’ve figured it all out.
Now what I want to know is how can I animate this?

Are you in sub object mode by chance? Seems weird it would complain that the mesh isn’t a mesh :slight_smile:

Just saw your edit. Start looking at some dynamics tutorials. There are some decent ones out there.

Dynamics tutorials? Okay - I’ll look for that. Thanks.

You need to deselect everything first, or make sure that one of the shards is not selected. After you make sure at least one piece is not selected, re-select that last part, then ctrl+j to join them. If you need to join those pieces to another sphere, do it after you have joined all the shards together.
Joining objects joins them to the last object selected, if you didnt have a “last” object to join them to, youll get that error.

Okay I’ve got it sorted. Thanks.