playing safe with tdrdelay

When I try to go to render 3D view in Cycles (GTX 660 Ti) it crashes with one of my heavier scenes (grass, trees etc) with error saying that it timed out. When I disable some of the objects mentioned it goes ok. I delved deeper and realized that changing tdrdelay (GPU timeout option) from 2 to 10 (as I found here ) it gets better but stil after zooming, rotating it crashes. So - anyone knows if setting higher values might destroy the GPU? The problem is only with rendered 3d view, not with the render itself.

Are you usingMSI Afterburner to check the heat on your card? Afterburner has a nice custom graph where you can draw when you want the GPU fan to come on. I have the fan on my GTX660 set to turn on to full RPM @ 60 degrees celsius. It could be GPU thermal overload protection is kicking in and locking up th GPU card…?

Thanks, I’ll check it out. Yesterday I set tdrdelay to 20 and it still at some point crashed. I wonder if I should use CPU for this and GPU for final render. But it’s ridiculous - if CPU can handle it why GPU can’t?

Hi Sandking, Windows “think” the driver/application crash if it not respond in “tdrdelay” time but the device is only busy.
You can switch it off without risk but if Cycles/driver really crash Windows does not detected it anymore.
As Atom mention, it is always a good idea to watch the GPU temperature during long render times and/or on bigger projects.

Cheers, mib

Ok, thanks. I just wanted to know if this tdrdelay is a switch for the GPU overheating and if I’ll turn it off it’ll just go without breaks. But I’ll keep an eye on temperature. What should be red zone temp? Is it specified by manufacturer or is there generally accepted limit?