Please help, having materials not display in the viewport

So I’m having this issue where blender won’t display my materials in the material preview mode. They instead appear the same grey as the background.

You can see it is rendering as it blocks out the grid, and it appears like this from the other side too. I’m using cycles and the material does show in rendered shading, for reference this is what it’s suppose to look like.

For more context this happened after switching to OpenCL in the cycles render devices so that I could use my GPU to render screenshots.

What I’ve tried:

  • Restarting my program and computer
  • Switching back to None (the other 2 don’t support my card)
  • Switching from 2.8 to the latest version (2.91.2)
  • updating my drivers (they are up to date at the time of posting)
  • Tried different render engines (only cycles will display the material)

I want to avoid doing a factory reset (or whatever it’s called) as I’m worried about what I might lose, but if there’s no alternative then I have no choice.

Thanks in advance! If there’s anything else you need to know hit me up!

  • Adrian

UPDATE: The rendered shading now bluescreens my pc, so that doesn’t work now. I’m running out of options here is I may as well do a proper reset of my blender.

Another update: I did a fresh install again, still no dice. The render engine is eevee and it’[s all default settings, tried using the zip instead of the msi install. I tried changing the colour of the material just to see if it were cos it were the same grey as the background, and interstingly the preview window is just black.

This is pretty epic my dudes.

If you’re using an AMD GPU, there’s a driver issue. Try the latest beta of 2.92, there’s supposed to be a workaround for some of AMD driver problems in there. But if that doesn’t work, you’ll need to downgrade your video drivers to a version before 20.11.2 and wait until AMD fixes their stuff or the devs find a way to work around all the problems.

Yaaaaay! Thank you friend, seems to be working on the beta version of 2.92. Man I was struggling with this for weeks!