Please help me with this problem.

I have just started using blender and am still learning how to use it. I have very little knowledge about most technical things (such as API, F-curves and a lot more), so I hope I am given an answer I will understand. Anyway, the problem is that every time I try to open the user preferences (I am planning to use the ATN? landscaping tool, for my first project), the whole program immediately becomes unresponsive and I can either shut it down or ‘search for a solution on the internet’. It is probably some kind of problem with my graphics card (I have a laptop) or RAM or something (again, I know very little about this kind of stuff), but i might have missed something. So please help me and try to give me a solution.

Ray Green

Do you have python installed? The landscaping tool is a addon, and most blender addons are python scripts. When you open blender a black box will appear (You will have 2 Blender tabs). Open the black box and read it to find out if python was found/initialized.

can’t be that. Python comes packaged with Blender.
sorry don’t have an answer for you
Post this question in the support section of the forum, you’ll get more attention there

Really? When I started in 2.4x I had to install python seperatly to use add-ons. Didn’t know they started packedging it.

First of all, thank you for the advice and help, i really appreciate it.
Also, the black box does pop out, but then disappears and leaves only one tab. I am not sure if there is any text, it goes too fast, but i don’t think it says ‘python was found/initialized’. Besides that, i looked at the files and there is indeed a python file, however, there is also another file called ‘scripts’, which contains other files including ‘addons’, ‘templates’ and ‘modules’… Is it possible that something was misplaced?
Anyway, i will post this in the support section (please tell me if there is a specific place to post it) and i hope someone will be able to solve this.

Ray Green

Did you download the right build? e.g windows 64 or windows 32.

Well, i just tried the 64 and what happened:
I opened it on installing and the black box did appear with some text, including something with python.
Then i tried to open user preferences and it did the same thing as before.
When i opened blender again, the black box disappeared and it does the same as before…

But thank you for trying, really appreciate the ideas.

oh yeah, what is the downloadable zip archive for, next to the download?

Go to help menu and toggle the system console; you should be able to see what the error is.