Please help! super stuck!

Whenever i add any texture in the shader menu it turns my base color purple. Why? very annoying, I really don’t want this color. Super stumped on this one. There are no linked shaders that are purple at all. I am adding blenders stock textures not an image texture. Still occurs even with image texture covering up the image with purple.

purple means some face isn’t unwrapped/mapped, although if you have a texture node input into base color it shouldn’t matter assuming you have a texture coordinate node or the shaders are fairly default. maybe you could try setting the base color slot, but it’s not required as long as you have a mapped texture. If you provide screenshots then everyone will have a much easier time helping you.

Here are some very ‘default’ texture nodes for example:

Thanks for the response, i have no idea where it is getting purple from. Maybe i just need to unwrap anyway. How do i do that? Sorry super new. The u button wont bring up the option anymore in edit or object mode.

Tried to just add a color shader and it just turns black for no reason. I also tried to turn nodes off, still purple.

Wave texture isn’t used for color, unless you use a color ramp to map it into RGB.
If you just want to displace the texture on the surface, use a displacement node (bump, displacement, vector displacement, mapping, …)
I mean ask yourself, what is the color of a wave noise?

edit: displacement:

Makes sense. Ill try that route. Why would they give you that option though?

1 Like

Trying to Link the nodes like yours but still purple.

Try adding the generated texture coordinate, or otherwise, please go to “UV Editing”. Once there, whatever object/faces you select will be reflected in the adjacent view. They map sets of points into 2d space (uv is what you call xy in the fragment and vertex shaders), pink is the classic transparent color which means that the space was unmapped. You could also just have purple lights. Who can say?

Maybe show world settings as well, I notice you have a completely black background.
So, although it’s probably not the reason for the purple, you could check these things:

So my giant sphere will allow me to pick the color now. However i have no idea why and afraid ill get stuck on purple again soon. Just messed with the nodes.

Also do i really need to use the UV mapping to just set a stock texture and color?
I had success in my last project texturing an object with out using the UV editer.

Also my smaller sphere on the bottom right is black now, but i do not know why. Really wish i had control over coloring. =/

Include the .blend file and I’ll be able to open it and see the problem.
It shouldn’t necessarily require a UV unwrap, but there might be some transparency or something I can’t guess about. As you saw from my node setup, it can be very basic and still work.

Crud, im too new of a user to upload attachments =/, dropbox or drive?

You may need look into some basic tutorials about shading and texturing in blender, and then try to work your project based on that.

Anyway , one thing that can help you is to look for colors dots in the nodes. In the last screenshot you’ve plugged a yellow dot(output) into a blue dot (input). While sometimes different colors can be compatible, you need at first to try to match them to be sure it will work.

The most important piece here is the Shader node (Principled BSDF) that must be connected to the Material Output in the Surface Socket. They both have green dots.
Shader nodes define how the material is supposed to work. And basically If they aren’t connected to the output your object will turn black. In the screenshot it’s the case, hence the result.

Then, you can use some textures , (images or procedurals) like the noise , wave, voronoi, ect…
They have grey or yellow dots that can only be plugged into a grey or yellow socket.
You can plug a yellow dot into a grey socket, or the other way around, but a green sockets will only accept green output to be connected in.

Hope that will help you a bit, but try to look for basics tutorials and then go back to your scene, you’ll save yourself a lot of time because guessing all that stuff by yourself may be quite difficult.
All that said, it’s not that complicated once someone shown you how to do that properly.

Good luck !

You can drag files into the reply box to upload them, assuming they are <5Mb

So things for no apparent reason started working normally again tell now. Again trying to add textures and even when adding a simple shader i still get the purple problem. Texture coordinate hasn’t helped. The tutorial i am watching now seems to simply connect a texture node and it works for him. Does not mention anything about UV mapping and it is an intro tutorial. Select, connect, and it works but not for me. Making learning shading really frustrating.

Tried to drag and drop the file but I get the same error message saying i am too new.

Of course it’s frustrating because you probably lack some fundamental knowledge.
Try to make basic exercices and follow tutorials step by step, you can also read blender documentation.
Learning by recreating basic tutorials is also frustrating. But when working in 3D there are a very few happy accident, you must have at least a basic knowledge of what you are doing.
But once you’ll have this knowledge you’ll enjoy much more working with blender it’s the same with other 3D software unless it’s very limited.

some time after saving my project and open it again it turn purple like this when i render it i figure that the lights was the problem just turn it off and on if u use pro lighting studio / if u use normal light try to delete it from the seen and make it again or hide it and bring it back

Are you using cycles or eevee for this project? This looks like a glitch to me.

If you were expecting a black and white sphere in your first screenshot, then that should have been the result, not purple. Purple is the error color blender uses when it can’t find a texture. It has nothing to do with transparency or lack of a UV map. Blender just uses generated coordinates when there is no UV map (based on the object’s bounding box).

If this is an eevee project, then try switching to cycles to see if the error persists. If it does, then its not a glitch in eevee, but some other issue.