Please Help, when i go to Wieght Paint Mode, my Mesh looks gray?

Help guys, when i select the armature in pose mode, and then go to object mode and shift click my mesh, and then go to weight paint mode - My mesh becomes gray, and i can’t CTRL+Click my armatures bones

when i CTRL+Click, the mesh gets painted on, instead of the bone gets selected. i must have accidentally pressed or clicked something else before it.

weight paint mode

Make certain the texture is selected inside the shader view, that you want to do the painting on.

You can try hiding the armature.

Check the viewport view settings, is it object, texture or render.

What version of blender are you using?

i’m using 2.91

it’s the same in all viewports bro.

It’s been while from last time i worked in weight painting. But I remember the bone must be selected, then switch into weight paint mode.

Have you used it before in this version? I know they changed the workflow in 2.83.

I tested it out with a model I had. In the vertex group panel, you select the bone you want to edit while in paint mode.

I tried to ctrl+click, but it only painted.

in other blend file it works. so it must mean i accidentally pressed or clicked something. or changed settings on viewport

Thanks. i found the answer: