Please help with LuxRender+Blender with a Mac

I really need help with this please. I’m trying to set everything up to where I can render my Blender scenes in Luxrender. I’ve already tried the tutorial on where it points me to graphicall, but when I narrow my search on graphicall to Mac OS X>Blender there aren’t any downloads that have Luxrender included as an add-on. Because of that I just decided to install the Luxrender add-on manually. But I’m having some trouble…

Below I copied the portion of the instructions that I’m having trouble with. I downloaded the stable version of LuxRender 0.8, which is at the very beginning of this portion. I found the “luxrender” folder no problem. But I can’t find my “<blender scripts>/addons/” folder. To be honest I don’t even know where to look. I have a Mac OS X and it says below to “please follow the instructions that are part of the LuxRender download.” but I am just completely lost. Where where these instructions in the download?

I’m just lost with this whole thing. I’ve never installed any add-ons in blender and if this will involve any scripts I have absolutely no experience. If any of you could shed any light on any part of this please help! Thank you :slight_smile:

> 2. Get LuxBlend25

The version of LuxBlend25 that works together with the stable version of LuxRender 0.8 can be found Once you have downloaded the zip file and unpacked it, you should see a folder called “src” inside the “luxblend25” folder. Inside the “src” folder there is a folder called “luxrender”. Copy this “luxrender” folder (the folder, not just the contents) into your <blender scripts>/addons/ folder. The exact location of the folder we are looking for depends on your operating system:

  • on Windows XP, it is either in Program Files\Blender Foundation\Blender.blender\scripts\addons (or C:\Program Files\blender-2.58-windows32\2.58\scripts\addons) or C:\Documents and Settings[username]\Application Data\Blender Foundation\Blender\2.57\scripts\addons. This latter folder is normally hidden, so you may need to make hidden folders visible first.
  • on Vista and Windows 7 it may either be the same location as XP or otherwise C:\Users[username]\AppData\Roaming\Blender Foundation\Blender\2.57\scripts\addons. This folder is normally hidden, so you may need to make hidden folders visible first.
  • on Linux it should be /usr/lib/blender/scripts/addons.
  • for OS X, please follow the instructions that are part of the LuxRender download.

You should end up with the following structure: <blender scripts>/addons/luxrender/ which contains an file and several other directories.

Oh and btw the instructions I included in the first post are from the luxrender site

Did you try this build with smallLux?

As for the installation, I think what you are trying to do is add the blender-side script, correct? Right-click on your blender icon, choose “show package contents” and then navigate your way to the “addons” folder in the resulting directory (I think it’s scripts/addons but I can’t recall off the top of my head). In the addons folder will be a lot of python scripts, maybe a few folders. You probably want to put your files in there, though I strongly suggest you read the instructions included with the LuxRender download…

Once the scripts are “installed” (meaning, copied to the “addon” directory), launch blender, go into your preferences, select the addons tab, find luxrender and enable it. It should work from there.

Disclaimer: I haven’t installed LuxRender for a while (ever since Cycles came out, which keeps me happy for what I’m doing), but I think this is the right way to do it…

Did Benu’s post help you?

Thank you so much Benu :smiley: I installed it, and enabled the addon and I see it in the dropdown list in choosing render engines. I only have one problem now. I was testing luxrender and I don’t know what’s supposed to happen but I know something isn’t right. It didn’t pull up luxrender to render the scene, it only went to the image editor and the image was completely black. What’s wrong?

Oh and btw I tried to download what you showed me in the graphicall link and it just repeatedly “unexpectedly quit” on me, so I’m just going to stay away from that.

Did you remember to set the path to Lux? (On OS X, the path you set is the folder containing, should be /Applications/LuxRender if you used the official installer)