Please help with Mesh Deform and Armature.


I’m trying to rig an object with a mesh deform modifier and an armature.
The armature is supposed to deform the mesh deform modifier AND parts of the mesh like the Chinchilla of Big Buck Bunny.

When I try to do so, somehow the parts of the mesh that need to be posed by the bones directly, also get deformed by the mesh deform modifier, so there’s a double influence I think.

After having examined the Chinchilla-blend for a long time now, I just can not make sense of it anymore.

So: to recap: I would like to be able to set up a mesh with a mesh deform modifier and an armature and the armature should deform the mesh deform modifier and the mesh itself (like the Chinchilla hands).

Does anybody know of a step by step tutorial for doing so?
I’ve been googling for days now and I’m on the verge of a nervous breakdown, haha:spin:


I guess I managed to get it to work but I still do not understand why.

I’ve put the Armature modifier of the mesh beneath the Mesh Deform Modifier and I think it works.
But in the Chinchilla-blendfile the order of modifiers is Armature ABOVE Mesh Deform Modifier???

I can not make sense of it, anyone can clarify this to me?


Apparently I had figured it out on my own as mentioned in my previous post.

The reason I didn’t get it was because I had an old Chinchilla blendfile.
Now that I have the new one I see that I did what has been done in the new one and it works.

Here are the steps that I did that made it work:

1 Create mesh-object (= hi-res mesh)

2 Create mdm-object (= low-res mesh deform cage)

3 Create armature

4 Create vertex groups for mdm-object (= bone-names -> except for bones that will deform the mesh directly like the finger bones)

5 Add Armature Modifier to mdm-object : fill in name of armature and select which deform you want (I only use Vert. Groups) --> here Multimodifier needs not to be selected

6 Create vertex groups for mesh-object (bone-names -> for all deform bones AND a vertex group that is not assigned to a bone and comprises ALL vertexes : I called it “allverts”)

7 Add a MeshDeform Modifier to the mesh-object (fill in name of mdm and for the rest I kept the default settings)

8 Add Armature Modifier to the mesh-object (and here are some important settings!!)
8A) fill in name of armature
8B) fill in name of vertex group (Remember 6 above? I called it “allverts”) !!
8C) Press the “Inv” button !!
8D) Select which deform you want (I only use Vert. Groups)
8E) Press the “MultiModifier” button !!

9 At the end you can press the “Bind” button of the MeshDeform modifier and the MeshDeform modifier should be ABOVE the Armature modifier for the mesh-object !!

It seems that the mesh deform modifier doesn’t like it when there is shape keys on the deformer mesh as well.

Thanks for replying TorQ,

But that was not it.
The problem was that my vertex group for the vertexes that are being deformed uniquely by the armature (called “noMdef” in the Chinchilla blendfile) did not have the right weights.

In the meantime I have posted a step by step for thos interested here :

Hi guys, here´s a kind of video tutorial about meshdeform. Actually it is about BlenRig, which is a rigging system I´ve developed, and it is based entirely on meshdeform, even for facial animation.

WOW jpbouza, very impressive.
That will be a great learning resource.
Than you !