Png and Transparent background

I have created a PNG file with a transparent background and I am attempting to place this onto an object in blender and use the transparency.

I am getting stuck when I try to render it out. (and I have pressed TexFace)

Here is what I am doing

  1. I Create a cube
  2. I Press F for UV mode
  3. Select one side of the cube
    4)In the UV window I select Image > Open > and select my png (It is a black drawing so I only see black in the UV window)
    5)I Click Alpha in the texture face buttons

I can now see my drawing on the side of the cube in UV face mode
I can see drawing on side in Object mode when the draw type is set to textured

If I render now I just get the grey box

  1. I add a new material and I select TexFace

If I render now that Face is now Black in the render ?

If I do the same process with another PNG without a transparent background it renders

The images I wish to use as billboards only output as PNG with a transparent background and I dont have any other options, as it looks great in the editor, I was hoping I can get it to render too.

I have tried png files from other apps with transparent backgrounds and have found that other issues but still no success in removing the background.

Help much appreciated

You’ll only get what you’re looking for via the texture buttons (F6) because the alpha button in the UV/Image editor is only for preview purposes and defines nothing. You’ll make it easy on yourself if you export your uv map and combine all images into a single map via an external image editor. Otherwise you can separate all faces from the cube, parent them to an empty and map them individually with single user materials. You may also be able to use the UV project modifier but I’m not sure if it supports alpha. I don’t really like it so I don’t use it.

see note

I really only want to put these alpha PNG images onto planes - I was just using the default cube to test so I have cant see what I am doing wrong - I have tried the F6 Textures and I can get it to map onto the plane and render but I cannot get the transparent background.

Sweeet this 2d cutout script did the trick ! awesome :smiley:

Ok hopefully someone can answer this on same issue really - I know have a PNG sequence created from flash with Alpha transparency , I import the sequence as a texture (f6) onto a plane

this loads in fine and play sequence in render - when I select material to be shadeless
but the background (the alpha is black) so I turn on alpha in Map Image and then when i render it is the colour of the material but still not transparent, however if I adjust the alpha setting the whole thing disappears, I have tried turning on texface but this does not make any difference expect force the background to be white - please help

Same when I bring in a quicktime movie with alpha

this has helped me :smiley: - sorry to answer my own post … again

Occasionally just switching from z-trans to ray trans then back to z can can stop things like this from happening. Another option is to use a non alpha image with black background then enagble Calc Alpha rather than Use Alpha.