PNG Image Texture Is Not Transparent Using Bump and Noise

I’ve set up Nodes with Noise and Bump on my main cube shape, and within the same cube shape (new material) I added the same nodes but this time with I added an Image texture so the material can look the same. I saw a tutorial with a MIX shader and diffuse BSDF, but I’m confused how to set it up, or if it’s the right shader to use.

If rendering with Eevee have you tried the Blend Mode options for your image ?
‘Alpha Blend’ under the ‘Blend Mode’ drop down, under Matrial -> Settings

Yes I tried changing the Blend modes but it didn’t work.

Alpha slider: 0=transparent, 1=opaque

Your alpha slider is set to 1, so it’s opaque. If you want only a certain part to be transparent, then you can plug in an alpha transparency map and use a color ramp to choose which parts are transparent.

Hi Blender Splendor.

I understand what your’re saying about your node set up. But what I have is one cube with texture, and Im tying to use the same texture on another part of the cube, but adding a logo. Can I share my file so you can take a look?

1 Like