PNG Plane layers out of order in render

The bottom to the “tower” is appearing in front of the mountains in render view.

However, it is supposed to be behind them, and is aligned that way in 3d view.

What is causing this issue and how do I fix it? Thanks!

It’s hard to tell from just that render, can you share a screenshot of the 3d objects in blender?

Here we are

The link is to the Blender file. As a new user I cannot upload to the site yet.

Edit: turning transparency off of the tower png plane fixes the issue, but then the tower is not transparent, which is needed. Don’t know if it is related.

Link is dead…

Sorry, used a bad website. Here it is:

hmm, there are no textures embedded, and all the materials on the objects don’t have any nodes.

But try setting the blend mode to alpha clip:
image

See if that helps