Point Cloud Visualizer

Is there any way to allow relative paths for loading ply files? Or perhaps assuming .ply file is in the same folder as blend file?

1 Like

well, no. regular (built in) file path property is editable as text and i did not want that, so i recreated ui to look like it, but it is in fact custom implementation of it. i’ll have a look if i can add option for relative path (if blend file is saved) in file browser (and in all other places path is used, in the end, it still needs to be absolute)

1 Like

Great add-on!
Is there any plan for importing point clouds in the E57 file format (https://www.wikidata.org/wiki/Q33517407)?
Or there are limitations?

in theory there are no technical limitations since the format is known… on the other hand, at glance it seems to be overly complicated, data are stored in chunks, not sure what performance i can get from python in this case. can you share some example files? so i can have a look? maybe i could put something together, as a experimental feature perhaps. if i find some spare time…

1 Like

Thanks for your consideration.
I’m asking 'cuz seems to be the standard format for sharing pointclouds between “professional software” (leica, faro, recap…), at least in the AEC industry. I usually convert them in ply with cloudcompare to use your plugin, but having a direct import option would be nice. That said, I agree that performance is crucial, so maybe ply is better.

Here you can get e57 3 dataset to inspect: https://shop.leica-geosystems.com/gb/blk360-dataset-downloads

Or if you prefere a smaller sample, here’s an exctract: https://drive.google.com/file/d/1WqdtoqvYJnT9FyibkFnq3SlhiGMZJDxt/view?usp=sharing

Hello,

I bought your library and have loaded my point cloud with it. I’ve successfully converted the point cloud to cubes. I then checked that the vertex colors were what I wanted. Next I wanted to export my point cloud to a gltf file.

My cubes are all pink!

Do you know why that is?

hi, i have no idea. i tried the same thing. made cubes with vertex colors, export (default settings), then imported back to blender and it have colors. i have no other software to open such files, but i take it as proof colors are there. i noticed this in export options, so i think make sure it is enabled. but other than that, i can’t be much of help. this is matter of blender exporter and application that read that file…

Screen Shot 2021-08-29 at 21.06.52

[Sorry I’m editing my comment because I didn’t read you reply well]

Could you maybe share your sample working point cloud file with me so I can check if the problem is with my files (I’ve tried several) or your plugin or blender itself?

ps: I’m on a mac and I’ve used open3D and meshLab (both free software) to open the gltf file and every cube is pink.

try this: https://gltf-viewer.donmccurdy.com/ (it is using three.js)

i updated meshlab to have gltf support, does not work as well, not pink, just grey, but it does not show that vertex colors are present.
i used 2.93.2 official release for export, nothing special…

points.gltf.zip (1.5 MB)

i still think it is a problem with software reading your gltf files, not with blender, gltf exporter or pcv

1 Like

Thank you for the gltf file. And the link that you sent me to view it.

I tried my gltf file on that threejs gltf viewer and I noticed something interesting!

All my colors are gone except for brown and black! And oddly enough those are the two colors in your model. I don’t know if this is a coincidence or now. I was wondering if you’ve tried your add-on with a point cloud with lots of different colors by any chance?

Cool! Clipping planes is awesome!
Would it work for normal geometry or it works only for poincloud?
I mean it would be great to have something similar to Alt+B clipping but controllable for any kind of geometry. Is it possible to do?

coincidence, blender vertex colors are in floats and so is pcv, look at this synthetic cloud

cube.gltf (562.4 KB)

only points, planes can be calculated automatically from an object bounding box, like here with animated scaling/rotating cube mesh

shader2-clip

1 Like

small update:

1.10.0

  • convert to geometry nodes with colors (blender 3.0+)
  • convert to mesh divided to even chunks
  • render points in 3d viewport together with other scene objects

and plans for future:

  • core rewrite because of bgl deprecation in blender 3.0
  • support for all scalar fields stored in files (like intensity, etc.) and displaying them
  • update open3d to latest version (after it is available for python 3.9), together with a few more extra functions
  • .las (maybe also .laz) support via https://github.com/laspy/laspy as optional install (like is open3d now)
  • maaaaaybe support for .e57 via https://github.com/davidcaron/pye57 if i can solve installation somehow
  • ?

if anyone have some suggestions, i would be happy to hear it. now is good time for changes

1 Like

Hello,

We use your addons and we have a long shot to render +5k images and we want to split the render across differents machine. So did you plan to handle the ’ Overwrite ’ option for render ? So it doesn’t render a frames already rendered or something like that ?

thanks

hi, rendering on two machines can be solved very easily with timeline start and end

for example this is your timeline

so on machine 1 render like this

and on machine 2

pcv will render only frames that are between start and end, those frames that show when you hit play button

thanks for your answer, but we have more than two machines the solution to split the timeline is not adapted in our case.

I coded a script to draw the point cloud when the scene it’s open and start the render. But I face a wall, it’s looks like the PCV render fonction need the viewport to be loaded to start the render.

then split timeline to more pieces, will work anyway.

i would correct it that blender needs a viewport in order to have bgl/gpu python module working and PCV working as well

In our case it will be tricky :wink:

Okay

Hi,

I face an issue with one of my render, maybe you can help me?

I have a scene with one point cloud loaded with PCV and an animated camera. I already did another render everything was good execpt this time.
The render has like a scanning strip moving away from the camera creating an unwanted stroboscope effect… I already tried to render it with a new scene or in the other scene whom work prefectly but I still get this effect.

Because of the privacy of this project I can’t show you a image here but I’ll be glad in private message.