"Polygon-index error" with OBJ export (solved)

I couldn’t find any clear answer on what the “polygon-index error” in Max actually means, so I decided to make a thread for archive purposes. I found other threads (in other forums) with the same error, but not any way to get rid of it… Hopefully it will spare someone from frustration and confusion in the future.

I tried importing a Blender-made mesh into 3DS Max 2010. I exported it as Wavefront OBJ, and tried to import it just as I had imported every other model from the scene… and got a mysterious “Polygon-index error”.

The problem was that I had a bunch of vertices in a line, and the vertices on the ends were connected not only to the vertex next in line, but to each other.

1  2  3  4

So 1-2, 2-3, 3-4 AND 1-4. After I removed the long, unnecessary edge and exported again, Max could open it just fine. So basically, specific types of geometry don’t work well with OBJ. I’ve imported dozens of objects without any problems, and so far it hasn’t come up with anything I’ve done on purpose, but the meshes have been rather simple.

If you have this problem with a complex object, you could try exporting the object in pieces and seeing which one causes the error.

Thanks a lot!! I think it’s the problem i have when i use transpose in Zbrush…it close! i try to find the bunched vertices!
well, it worked!!!
i used the clean meshes script, in edit mode (2.49) and removed free vertices and shorter edges.


I had this same problem trying to open a model I had done retopology.
Tried to open and gave this error.
I decided to open the template in the blender, selecting the whole mesh in edit mode.
Then I went to select / Non-Manifold.

I removed all the vertices and lines that were loose inside the mesh and exported it again.

It worked perfectly after that.


Douglas Liell