Polysweeper 0.1.5

Great, it would be really cool. :+1: :+1:


new feature: MULTI SELECTION MODE for sweep and extrude op:
Since multi mode will slow down the operator I added a global option.
Obviously a single selection would work in multi mode but a little performance cost.

here the reference to add a keyboard shortcut:


hi, with the update, i keep encountering this error where the base of the profile keeps extending. can you help me?

Yes, can you send me a blend file?

same happening to me

Could be the multiselection option?
If you want to sweep or extrude on different selections at same time you have to check it

Hi nice thanks for the update :slight_smile:
I like multiple selection and it’s work well, but in certain case it’s “invert” or rotate the sweep between two face, can we lock the sweep in the same direction ?

1 Like

At moment also in multiple mode it works based on cursor position, but we could have a xyz checkmark to lock the orientation…
In the video you posted maybe you can try to place the cursor over the selection

1 Like

Yes, you rock :slight_smile: lock the orientation will be greatt :slight_smile:
I’ll waiting for your next update :wink:

1 Like

At moment, this is what happen under the hood…
The cursor works fine with one selection but in multiple mode could be tricky…

1 Like

Sorry, I can’t upload through this forum since I am a new user.
I set up a link instead https://drive.google.com/file/d/1-kFd9Lg4WQdJQousc3DWd-9z7qYRPEmt/view?usp=sharing

this is not the exact file since I tried to simplify the faces. it’s still buggy.
this time when I tested, it produces an error. “wrong loop selection”

the only time the add on works properly is when I have a straight forward shape with clean loops. I wish I could use it on more complex like furniture since that’s the area where I really want to use it.


It require a face loop like input, in your case a workaround could be duplicate the faces strip and use “limited dissolve” command to remove unwanted verts to convert them in a proper loop, let me know

The better is to fix manually the loop, like this:
Screenshot (142)
fixed loop:

BugReport_Polysweepe_01.blend (2.1 MB)

1 Like

ok thanks this worked. Would you recommend always creating duplicates of faces first before polysweeping?

Also, does the origin of the profile matter?
Sometimes my profiles works, sometimes it doesn’t. They’re all on the X Z axis. I’m using an asset manager called level builder to deploy them on my scene. Whenever I change the origin i will get this error, even tho i re assign the profile and re-select the profile face. Everything works as expected when the origin remains on the bottom center.



Good, for scenographic models with no subd modifier I prefer to sweep the profile with fuse option off, so you can easily select (“select Linked”) delete It and make a new sweep, it is not necessary to duplicate Path.

The rotation on the profiles object has to be applied , can you send me also the blend file with the profile not working?
Maybe I can add more code to manage excepions but I prefer not, let’s see…


Here’s my file. https://drive.google.com/file/d/1-kFd9Lg4WQdJQousc3DWd-9z7qYRPEmt/view?usp=sharing

Thanks for looking into this.

Thanks for the report!!!
The problem is math side…
At moment could be easily avoided don’t placing profile vertex on local origin

here the fixed .blend
BugReport_Polysweeper_profile.blend (2.1 MB)

1 Like

This solution is not ideal, it feels wrong and hacky not to have pivots in origin which is common sense in gamedev, modular assets etc :frowning:

I understand the point, I never had this problem because I store a lot of profiles inside the same object!
And I have different objects for styles (classical, subD, sci-fi ecc)…
If you need the profile to be a single face object with a vertex on origin it’s not a problem to fix, I just need to add an exception to 0,0,0 vertex in the next release.


awesome thanks! looking forward to that update

1 Like

Don’t have much to add right now but just wanted to say this is one incredible addon! Always wanted this easy sweep functionality.

1 Like