Poor video render quality

Hi Guys

I’ve got another question for here.

As usual, I’ve got destracted from Kung fu Cuby, and got trying things out with this lightsabre short me and Darth sirrah1 started a while ago, but never got round to the lightsabre itself.

Anyway, when I render a frame from the movie in blender, it’s stuffs up the render quality, and doubles everything that moves with previous frames. This is deffinately blender doing this, as when you whatch the clip it’s fine.

Why does blener do this, and how can I fix it???

Here’s an image of the original frame, and then the blender render…


P.S The render is currently on a shadeless plane, but I get the same effect using the sequence editor.


Does it do the same if you save it to a sequence of jpg files?

Yep, it seems to do it for all the different formats.

What frame rate did you use for your original video? Change your Blender render to that rate, because the default frame per second rate in Blender (F10) is 25 fps. Your original video could of been at 24 fps or even 29fps. You might want to check that out.

Nope, that doesn’t seem to change anything. I’ll try turning the clip into different formats…


Very strange. Ok what about importing your film into the sequence editor via Shift-a>movie. Then in F10 press the ¨Do Sequence" button and render as bunch of jpegs like IKbanat said.

And then reimport these jpegs into the sequence editor and render them as an avi movie and pick whatever frame rate you want. Good luck!

On first look I would say the same as ozo, framerate problem. Have you tried 29.97 and 30 fps ?

It could have to do with de-interlacing, however your first pic doesn’t seem to be interlaced. But if it is, the problem might be that blender is blending the fields to get 1 progressive frame. Video shot with camcorders is usually interlaced, meaning even if it’s 30fps there’s actually 2 fields per frame. Are you directly using the DV avi file you captured?

I don’t know blender too much yet, but in the render settings you got some settings for this. Try the “Fields” button. Or even the “Odd”, it inverts the fields, but it would be strange if thats the problem.

EDIT: Actually don’t use “Fields” in the render panel, do it in your texture settings. Sorry.