Positioning image planes with premultiplied alphas?

I used the import images as planes plugin to import a sequence of images for 2D puppet animation, and I encountered the problem illustrated below; it is very difficult to line up the planes properly in the viewport because the alphas are messed up, which is a big problem for animation. They look fine in a standard render and in the game engine, with and without GLSL shading turned on.


Note: the artwork is Derek Yu’s, from Aquaria; I’m just using it here to illustrate the problem.

Is there a way to get the planes to display properly in the viewport so that I can position them properly? It looks like this is a problem with how premultiplied alphas are rendered in the viewport. Is it a bug?

I can’t re-create your problem. When you import with the “images as planes” add-on, are you making sure to activate the Shadeless, Use Alpha, and Premultiply boxes?

You could also try changing the render mode to “Blender Game Engine” (dropdown menu next to the Scene selector on the top header). Then select one of your planes and open its Material panel. Under Game Settings, set Alpha Blend to “Alpha Blend”. Then you can switch back to the normal render engine. The plugin should have done this for you already, but it’s worth checking.

Thanks for your help, CD38.

I had all of the settings you suggested already set. Out of curiosity, what version, platform, and graphics card are you using? I’m using Blender 2.62 standard, Mac OS X 10.7.3, and an AMD Radeon HD 6770M card.

I didn’t know about the Alpha Blend settings, and while they were set to ‘Alpha Blend’ by default, changing them to ‘Alpha Clip’ let me see the body parts overlapping one another properly, which solves my problem.

This isn’t ideal because I obviously get black fringing around the edges of the images in the viewport, but it serves my purposes because the output render still looks fine and my ultimate goal is to generate my own 2D artwork, animate it, and use it in Unity, not in the BGE.

From a UI paradigm standpoint, though, modifying the game settings to change how an object appears in the viewport in standard render mode seems to make no sense at all.