Possible 2.79a bug

(Wig42) #1

Has anyone noticed in 2.79a that it doesn’t remember some settings. For example if you bevel some edged, then select some other edges the bevel amount is reset to zero again and you have to type it back in. Is this just me, is the a setting to make it remember this or is it a bug?

Cheers. Wig

0 Likes

(rboxman) #2

I think it was this item: https://developer.blender.org/T53145

Follow the thread starting at Brecht’s reply on Nov 26 2017 and it led to the following commit: https://developer.blender.org/rB2bf382571126382d80bd12b471324d38a480cd6a

0 Likes

(özgür) #3

Select other edges and Shift R

0 Likes

(Wig42) #4

Thats OK but what about if I do 40 or 50 different opperations before nedded to bevel again. I was just wondering if other people had the same issur. Because it used to work until I upgraded to 2.79a.

0 Likes

(rboxman) #5

Yeah, I don’t much like it either. Shift-R is unworkable, generally, since any other little action that it decides to record in between will mean you can’t repeat it.

I think saving settings for some aspects of each operator is very workflow friendly (regardless of style of workflow). I think it would be worthwhile for someone to go through all the common operators (bevel, inset, etc.) and request a design change to the devs for each setting that is worthwhile to remember. You can’t file a bug on them for this though; they don’t like that. Asking a dev to “sponsor” the change in IRC or here on BA I think is our only recourse. Alternate suggestion would be to improve Shift-R somehow…

0 Likes

(Cyaoeu) #6

If you want the behavior where it saves the bevel value you can build Blender yourself, change the code (https://developer.blender.org/rB2bf382571126382d80bd12b471324d38a480cd6a remove the green line here) and rebuild.

0 Likes

#7

me no like it either :no:

i’ve also just noticed, that when grab-moving objects/nodes around ‘canvas’ when cursor crosses the border (& starts again from the opposite side) those objects/nodes jump the distance for one iteration more. So damn annoying. :rolleyes:
Both, 2.79 & 2.79a seem corrupt.
2.78c is fine.

0 Likes

(Lobber) #8

GPU+CPU rendering worked in 2.79, but after updating to 2.79a (dated 21.02.18) I can’t find the feature?
Has it been moved from user-settings, or is my memory failing me?

0 Likes

(Jason van Gumster) #9

It was (and is) only available in the nightly builds (or if you compile yourself). The official release of 2.79 never had that feature and 2.79a is exclusively for bugfixes.

0 Likes

(brecht) #10

About the bevel issue, as far as I can tell the official 2.78, 2.79 and 2.79a releases all behave the same but for some time in the daily builds it worked differently. If that’s not the case, please explain how it is different specifically here: https://developer.blender.org/T54206

Seems like a bug that can be reported.

0 Likes

(rboxman) #11

^^^ Eh, beaten :slight_smile:

0 Likes