possible bug and correct way to do alpha and transparent channels

I have been billboard texturing trees - simple planes with an image mapped to them. I was using a single texture channel - a png image of a tree with an alpha channel. I set the material alpha to 1, then the texture channel to:
Col:On
Ref,Spec,Amb,Alpha: On yellow
Dvar:0

The image on the plane loaded fine, but the shadow appeared to glow (see attached).

If I change all the texture settings so I have the material alpha to 0, then a texture channel with:
Col:On
Ref,Spec,Amb: On yellow
DVar:0
…and a second texture channel of the identical same image with
Negate:on
Alpha: on
DVar:1

then the image and shadow work fine.

Is this a bug in blender? I can’t imagine glowing shadows are ever desirable, but I also couldn’t find anyone else with the glowing shadows problem searching the internet. Why does the second way work and not the first? Surely they both should have the same effect except that the second takes twice as much work?

Attachments



Turn on the PreMul button for the tree textures. Your material alpha should be set to zero and the PNG texture should have COL and Alpha buttons enabled in the MapTo tab. Also, don’t forget to set your specularity to zero.

Thanks Atom, Where do I find the premul button for textures?

In the wiki for the premul button in the render settings it says “When Blender reads RGBA files, “Premul” is considered the standard.”
http://wiki.blender.org/index.php/Doc:Reference/Panels/Scene/Render/Render

Surely it is a bug though that the shadows glow (see 1st image)?
any devs out there?

I submitted this to the bug tracker as its still happening in 2.5.0