Possible to have transparent root for hair particles ?

Hello, I can’t use to much particles for a character I’m creating then I’m using large hair at the roots to get more volume.
The problem is that the roots are visible at some places, also I think the result will be better if I could make the root transparent just for some milimeters, just not to see the root.
Is there something without using cycle for that ?


Back when I was using BI for rendering I would apply a gradient texture along the strand to get both roots & tips to fade out. I’d have to dig around to get the details, but the basic answer is “Yes, you can,” by using the gradient in the Alpha channel of your hair material, and having it aligned along the Strand.

Good to know but I don’t see how I can align the texture with the strand…
I’m actually using a texture with the same uvs as my character’s skin to change the hair color…

I’ll have to look into it, it’s been years since I used BI for hair, and my brain’s not the world’s best flashdrive lol.

Use a blend texture with a color ramp. In the mapping section change from uv/generated to strand/particle change the blend type to multiply and make sure it is affecting the alpha.


That’s it, 'brat, good call and quicker than most normal human beings lol (just got back from Memory Lane myself lol). But I also find it necessary to enable “RGB to Intensity” in the Influence options (just below the blending mode = Multiply).

The Blend ramp can also be RGB only, from black (transparent) to White (fully opaque). Sometimes this is more useful than ramping the alpha.

In the main Materials specs, be sure to enable Transparency/Z Transparency & set the Alpha there to 1.0 (or less if you want some transparency along the entire strand).

It’s been a long time since I used BI, too. I forgot all about that option. Thanks for the additional info.

OK, then it works by:
-adding a second texture with blend and color ramp from alpha 0 to 1
-checking alpha (1) and unchecking color for that texture and let blend to “mix” worked for me (multiply make it totally transparent)
-selecting “strand/particle” for mapping but with “sphere” projection else some hair are not correct
-using z-transparency with alpha to 0 (1 make it opaque) in the material properties

I attached a

Thank you for your help !


gradienthair.blend (1.08 MB)

Using “Mix” is why you had to make the Z-Transparency Alpha = 0 because your ramp is Mixing opacity (white on the ramp) back into the material. If you set the Z-Trans Alpha = 1, then using Multiply for your ramp is the correct setting, as the black part of the ramp then becomes the transparent part of the strand. In the long run Multiply is generally more versatile, but either works as long as your settings & color “math” agree with one another.

OK, it works too, thank you for the precision !