Possibly corrupt hard disk?

I think my hard drive with Linux on it has been corrupted in some fashion. When I load windows, it works fine, but when I load Linux, I get this
Checking root filesystem
/dev/hdd1 contains a file system with errors, check forced.
/dev/hdd1: |============= %checked(terminates at about 40%)
Inode 1457053 has imagic flag set.

(i.e., without -a or -p options)
Failed to check filesystem. Do you want to repair the errors? (Y/N)
(beware you can lose data)

If I hit Y it begins a long process that doesn’t seem to do anything. It’s been running for close to two hours (I’m typing on an old computer). Is there a way to access the Linux portion from Windows, just to resuce a few files, mostly Blender related, all of them compatible with Windows. If so, I’ll just copy those and reformat the disk. I really don’t want to lose some of those files so I could really, really use some advice here.



Err, not anymore anyway. I went into it’s maintanence mode and ran “fsck -t ext3 /” 3 times, and finally it got all the errors out.

Now if only Windows worked…

fsck shouldn’t run for two hours. Have you tried to reboot the computer, using a boot/root disk, if you have the linux disks you can make boot/root disks using raw write on windows? Then you can save the files you want. It sounds like a virus, or did your computer shutdown with out using the shutdown command.

Umm, ok The only boot disk I’ve got for Linux was one I created to install Linux. I tried reseting it with the disk in, but it just tried to get me to reinstall Linux. I do have to Linux cds. HOw would I go about making the disks you’re talking about? I’m thinking it was a virus, but I’m not sure. The last person to turn of my computer was my little brother, but I’ve told him how to do it, and I’ve asked him what he did and it seemed normal. One possible improvement… I’m running the disk check and it got to about 70% before finding an error. Before it was 40%


:smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley:

OK, It’s fine now. I ran fsck (I think) another time and it finished fixing the errors. Yeah! And it looks like all of my data’s fine

Me now go and back up all .blend files


Thats good news!!! :smiley:
It sounds like it got turned off without using the shutdown command.

although it may look like it’s fine it can be that some data is lost.

you should look in your lost+found directory and if there are files there.
then that are the lost inodes that fsck couldn’t relocate for you.
you can do it manualy thou. for text files it wouldn’t be a problem. binairies would be a bit more difficult :stuck_out_tongue:

I re-formatted a boot sector once…

BAD idea…