Potential pitfall with playback of animation

I noticed today that my animations that are animated at 30 fps seem to play back faster in windows media player and quicktime than they do in blender’s built in player (“playback rendered animation”). To confirm my suspicions I made a simple animation and set it to 60 fps. Should have zipped right by, but it didn’t. Next I set it to 2 fps. It should have crawled, but it didn’t.

I’ve come to the conclusion that blender’s video player plays at roughly 25 fps, no matter what the animation is set for. A major flaw as far as I’m concerned.

Suggested workaround: in the Anim panel in the render buttons, enable the Sync button. This will at least give you real-time playback in the 3d window (if your computer isn’t fast enough, it will drop frames). Edit: This seems to only work with ctrl-a. Pressing the play button in the timeline plays all the frames, even if it can’t play them fast enough.

Has anyone else noticed this? Is there a better fix/workaround? Any kind developers out there who are willing to fix this problem? :smiley: