PovAnim question


(EnV) #1

Can anybody tell me why, when I export a Blender scene with PovAnim, the exported files is only for MegaPov07? I tried to change the setting in the script to PovRay 3.5, but the result is always the same…

I have Blender 2.23, the last Python and just installed PovRay 3.5, but I can’t get a PovRay exported file: only MegaPov.
Any suggestion?
Thank you.

Env


(Riskbreaker) #2

That was the same for me at one time, when i got the newest version, it worked fine. If you already got the new one (14 or something) then try this: when you open the pov file, open all files associted with it (lamps, materials, etc). In povray, you probably know this, you can edit pov files. Just remove the line where it mentions MegaPov (usually the first line).
That worked for me.


(jms) #3

Hello,

First delete the “meganim” directory created by the script.
Then, look at the Main frame.

There is a button named “Megapov0.7 compatibility”, under the
title: “Blender to Povray35 Anim exporter”, just push it.
“On”, you can use megapov’s postprocess boards and export in
megapov compatibility, “Off” the export is only compatible
povray3.5.

Did you try to set the patchtype to “0”? Really,
I don’t Know why this have no effect.

Good choise.

You don’t need of this, the blender python is enough,
but the xptrueA_xx.pyc file and blend file have to be in the same
directory (or xptrueA_xx.pyc file in the blender [".exe", for
windows] directory)

http://jmsoler.free.fr/util/blenderfile/images/povanimgui0.jpg
jm


(EnV) #4

Thank you very much, jms, for your aswer; i’ll try this afternoon.

Bye

Env


(EnV) #5

I did it! It works! Now I can export scenes to render in Pov! WOW!
Thank you very much, jm; a wonderful script.

Env