Predicting Particle System Emmission

Hey All,

I’m having difficulties predicting where my strands will be rendered when using a hair particle emission system. The trouble is that I have an object coming into contact with a plane that should not be transected by my emitted strands.
When rendering a frame in the preview window the particles are emitted such as they do not intersect my model.However, when I render the scene with the renderer then they show up in different places than in the preview.

Why the discrepancy? How can I predict where my particles will be emitted? Is there a weight paint type of option that I can use to exclude certain areas from emitting particles?

Any advice would be appreciated.

Cheers.



Moved from “General Forums > Blender and CG Discussions” to “Support > Particles and Physics Simulations”

Hey !
What you could try is using a texture in order to tell where there must be particules or no (Black for “No Particules” and White for “Particules”).

Open the textures pannel, add one, use you image textures, and scroll down to “Influence”, then ckeck the box “Den” (Density).
Exemple with a simple square-ish map :


  • T

You can certainly (and should) use vertex groups/or mask to just stop emission in that area. That beings said your viewport and render should be the same as long as:

  1. child particle number are the same as viewport (or simplify is not on)
  2. The stack in the same above the system, the above is a bit typical of a subsurf above the partcle with viewport set to1 and render to 2 (they should both be the same)

You had it right Photox. The seed on my children was set to 1 and 3 respectively on the particle emission. I switched it to 3 in the preview and it matched what I was seeing in the render. Thanks!

I’ve always had this idea for a button in the stack, something like “copy all viewport settings to render settings”