Pressing G in the UV-Editing totally streches my mesh, instead of moving the vertices

I’m using 2.60. Depending on the mesh, and maybe other factors, if I am in the UV Editing window, and select a single vertex, I can move it with G without problems. But if I select many, and in particular if I select them all, pressing G just result in my mesh being totally stretched and distorted, but doesn’t even put me in grab mode. What’s going on?

I found a work-around by selecting a single vertex in the middle, using PEF (Constant) and making the “area of effect” (circle) big enough to contain all the vertices. But this is still very annoying. Why is Blender doing that?

[EDIT] I spoke too soon. There are some vertices that I cannot grab at all; even individually.


Just out of interest. Did you use the “smart unwrapping” option?

Someone else on site was complaining that the smart unwrapper, was projecting the uv mesh BEYOND the image boundaries in the UV editor.

I have recently run some tests in Blender 2.5+, and found that there are some underlying problems with the smart unwrapper.

If the keep mesh within boundaries option is selected in the editor, the scale and grab functions are mis-behaving.

It looks to be a potential bug, but I am still running tests.

If any other member has an answer or a bug confirmation, please post for skunkiferous.