Preview render not working for anything other than camera view


I have obviously changed a setting somewhere, but I can no longer get a preview render from any view point, it only renders when using the camera view. What did I do? :slight_smile:



upload an example blend file so we can see… preferably something quite simple.


A default file works ok, but I cannot figure out what I have done to the one linked above. When you open it it should already be in preview render mode, but nothing should be rendering (i.e. the problem), but if you press num 0 to view the camera view it will start rendering. If I open a new file then preview will work from any angle.

Uncheck “Render Border” from the viewport settings:

The render border for the regular views is different from the one for the camera. I assume you accidentally defined a render border for the 3D viewport somewhere off and/or with a very small size. That’s why nothing seems to render…

Or hit CTRL-ALT-B (I think) to clear the render border.

Thanks, that was it!