Principled BDSF Normal removes smooth shading

So this happens EVERY time try to use normals. Whenever I plug something into the shader, the object in question is lit as though smooth shading was turned off. I have watched dozen of tutorials and have never seen this happen to anyone else, EVER. And that’s pretty clear because I also can’t find a solid solution to this. How do I stop this from happening?

According to my own searches, this could be happening because the Normal section of the node only acts correctly when dealing with non-color data, but as you can clearly see in the image provided, no color data is present on the path, so what is going on? If there is color data there, how do I get rid of it? Why is this happening and how do I make it stop?

The only work around I have found is using an Image Texture node and setting it to non-color data and plugging that in DIRECTLY, that is the only time the smoothing is not removed, but if I’m trying to make the normals using the shader in blender that isn’t really an option.

Thanks in advance.

For bump to work well your strength/distance values are very high, I know it is the default but the default is way to high. I recall one person saying that the distance value of 1 represents a height level of one metre!

To fix turn them down. Here I have an unsubdivided monkey with a similar setup as yours but I reduced the bump strength drastically. The lower the strength the less “flat shade” it is, this has to do with how bump is calculated.

With smooth shade on.

And for comparison

With smooth sade off.
Edit: I changed the pictures!


Huh… that actually worked! Dang, guess I’ve just been making things to intense then. Totally my B. Knew it had to be something simple. I just toned my bumps down a bit and now the effect seems to be gone (now it only looks like it does due to the poly count). Still confused as to how some of the videos I watch don’t seem to have the same issues, but hey it doesn’t matter so long as I have a fix.

Thank you!

1 Like

Yes, bump has to be subtle I do not know why the default is so high!
Over a certain amount the effect does not really gain anything.