Principled Shader - Need an Idiot's Guide

So, I opened Blender, turned on Cycles Render. Added Suzanne. Added a Material, checked Use Nodes and selected Principal Shader.


Nothing like ANY of the examples.

So either I’m missing something in the process or missing something in the hardware.

My guess is there’s some prerequisites for this to work.

So, something along the lines of:

Do you have…?

Did you…?

Did you remember to…?

If you don’t have … it won’t work.

Probably in order.

I haven’t had a chance to get caught up in any of the ooh and aah of photorealistic design
because either it doesn’t initially work for me, in which case I have to go fishing for whatever
I might’ve missed that needs to be done, in place in order for it to work. Do that, and see what
happens or maybe I just don’t have what it takes for it to work.

I don’t have an NVidia or an AMD graphics card - Intel is what I’m using. It came with the laptop.

Maybe using a laptop isn’t the best method.

My laptops are either I5 or I7 cpu with at least 8 GB memory.

Running Linux - maybe that’s a factor.

Maybe I don’t have the scene properly setup or there’s something else I didn’t take into account.

Or. Or.

Either it’s super simple and I’m just missing it.

Or, maybe I should just skip it.


Using Blender 2.79

Used Blender Guru’s Youtube Guide on the Principled Shader for reference.

post the scene, images… can’t see what you’re writing about

pbs_blend.blend (3.04 MB)

Very simple.

And not working.

Ergo, either I’m doing something wrong OR something isn’t working OR both.

looks right to me. try adding some lights

Also, post what you think it should look like. Nobody can help you unless they know what you’re actually after and trying to achieve.

It suggests that if I do nothing else but what’s shown, I’ll get the same result. It doesn’t say, make sure you have this or do this.

It’s pretty simple and straightforward and not what I’m getting.

So, either I shouldn’t have to do anything more or the information is inadequate.

For best results, add an HDRI to your scene (as Andrew has done, even though he may not have shown that). At the very least, you should have a lamp in there as Daedalus suggested.

Indeed, all you are missing is the HDRI environment for lighting and reflection.

Followed your recommendations. Result is MUCH more consistent with what I was hoping to achieve.

I had been using a matcap. But, matcaps are very inflexible.

Cycles Render PBS seems to be a better way to go. But it first helps to know
how to use it properly.


Here’s a short video I used for the process of adding an HDRI.

The only thing i did different, consistent with what I’ve seen others do is, under
Render / Film, I checked “Transparent”.

Your suzanne should be subdivided (i.e. ctrl+2) and have smooth shading enabled for the object. Although clearcoat may have some issues in the release version (guessing this in an older Andrew video which might not have this issue) which shouldn’t be related anyway, your settings differs from his even in the principled shaders parameters (subsurface enabled, different base color etc). He might also have filmic enabled, I didn’t check, but it shouldn’t affect things that much in this case.

Sorry, I missed post #2, but yeah, a direct timelink to video would be preferable.