Probably Noob Question - Edge for toon shader not showing on some objects?

So I’m trying to build a very simple evil robot Christmas tree for an animation I’m doing at work and need it to look reasonably cell shaded.

As you can see from the attached pic, when I render it with the Edge threshold on, some objects don’t show an edge, and it fact, object behind them incorrectly do. (It’s as if Blender doesn’t even know they are there.)

The objects in question (A star and some buzzsaws) were built in another 3d program and imported into Blender as obj files, so I wonder if this has anything to do with it?

So is there a way around this? Am I able to convert these objects into a mesh Blender could see? Right now my edge threshold setting is very low, but the results are the same even when I max it out. Thanks for any help.


Try Freestyle, it’s much more refined and controllable with much better anti-aliasing for the lines. You can even tell it where to draw edges by marking them in edit mode in the exact same way that you mark seams.

Aw thanks dude! I was still using 2.65 so I upgraded to 2.69 and am thoroughly enjoying the built-in Freestyle support. It seems like every time I have a Blender question, the solution seems to be - “The newest version of Blender does that now, so download it.” :stuck_out_tongue: lol