problem appending armature with action


(giobbo) #1

hi all,
i created a character rigged with armature and a few actions.
if i append the caracter and then i go to dope sheet in the action editor i can’t see all of them.
when i was working on them i noticed that and i tried to do some test.
i created action1.action2,action3,action4, saved and then tried to append in another file and in the action editor there was only action1,action2 and action3, so i created a new action (action5) saved and tried again.
in the action editor now i had action1,action2,action3,action5.
again i added a new action6 and blender appended a1,a2,a3,a4,a6… seems blender can’t append properly the actions, every time i create a new action and append the character blender changes the number and the action he appends.
to be clear i dont append actions, i append the rigged mesh and blender appends armature and some actions
it is my faoult or what?
ps:i have an action i can’t delete, dunno why. tried to unlink action and clear animation data but still there
thx for help


(stilltrying) #2

A blend would help. Post your original blend. Or if you just want guesses we can do that. Could be you enabled an F. Could be you stashed it in the NLA. Could be you didn’t save the action. Could be you didn’t append at the object level. Could be you hit the plus button instead on the X button. I’m sure there can be a lot of other guesses. Post a blend.


(norvman) #3

I second the idea that you need to post us a file… much to many variables to work from just your explainations…

one thing I can comment on… generally speaking if you want to get rid of actions you have to close out your blend file then reopen it again to see the change…
I know… it’s a crazy blender thing…


(giobbo) #4

here is the .blend

right now if i try to append the object in the action editor i have only this action:

i can not remove this
posa1
posa2
posa3
posabase


(stilltrying) #5

Go to blender file in your outliner after getitng rid of your search. Expand the actions and right click your action item you want to get rid of. Scroll down and left click Delete. If you can’t find it post back.


(norvman) #6

wish I could download from you site…
but I can’t…
Try using

http://pasteall.org/

note there is special .blend file icon in the upper right hand side…
post it up there…
come back here give us the address please


(giobbo) #7

http://pasteall.org/blend/index.php?id=49122


(stilltrying) #8

Go to your NLA. Unlock and unmute your actions you want to import. Delete the bar in the NLA and it will bring back your action keyframes. Then you can append them if I understand you correctly.


(giobbo) #9

hum, if you can be more accurate or post some picture… i dont know how to procede
why is so intricate to delete/work with action in blender?


(stilltrying) #10

Go to NLA. Unlock, unmute your strips (little lock and speaker). Select your strip. Delete. This puts them back as an action. Do all of these. Save your file. Now you have your actions back. When you push them down to the NLA, they are not actions, they are NLA strips. You need to put them back as actions if you wish to export or append as actions.



(giobbo) #11

ok i will try thx


(norvman) #12

Another way…

Goto your Outliner…
find plane… (for instance)
look under ‘animation’ …
Right Mouse Button (RMB) on your track that says ‘can not remove this’…
on the flyout menu select ‘delete’…

I know it’s a pain…

Blender 2.8 is supposed to start addressing some of these ‘hidden’ features issues…
but still might take awhile for Blender to cover everything…
Remember Blender is Open Source… so it’s somewhat of a Jury rigged piece of software…
but hey… it’s free… and it works… so don’t complain too hard… instead get in there and help the developers know how you want it to work… they don’t know until you tell them…


(giobbo) #13

ok im done thx all


(norvman) #14

Got deal… please mark as solved…