problem applying vertex colors on overlapping meshes

hi,

i just stumbled over the issue that the vertex paint module by default limits application of paint to non-occluded geometry and seemingly offers no preference to change that behaviour. the face selection masking does have no effect, hiding geometry in edit mode before switching to paint has neither and the tools and options tabs also do not show me anything relevant.
in texture paint mode however there are options to occlude, cull and mask paint…

this is what happens if i try and vertex paint my mesh:

any way to apply vertex paint into the cavities and semi-occluded ares of a mesh at all? breaking it up to paint individually would not be a practical solution, neither is texturing it with an image and then baking the result to vertex colors (shared UVs).

for an alternative solution: is it possible to import polypaint from zbrush into blender?

at any rate i will contact the blender guys about unifying paint settings between texture-, vertex- and weight-paint modes where it makes sense.

Attachments


Hey, I run into the exact same Issue (also with Hairs). I saw you got it included in a custom branch, nice! Did you manage to contact any official Dev? I remember running into this issue every once in a while when attempting to apply a Gradient Color to the vertices of a tree or whatever. Vertex Painting really needs some love!