problem building blender

It makes some SVN updates that I get this error message :
scons: *** Source /usr/lib/libstdc++.a' not found, needed by target/home/val/blender-svn/build/linux2/bin/blender’. Stop.
scons: building terminated because of errors.

My computer: Ubuntu 8.04, Pentium M processor, Intel GMA.

My last succesfull build is the revision 16578.

Do you have libstdc++? If so, do you have the dev packages?

http://packages.ubuntu.com/feisty/base/libstdc++6

I have the following packages: libstdc++6 and libstdc++6-4.2-dev.

is this the first time you’ve compiled? if so then it’s possible you haven’t checked out the libraries that are needed.
try doing an svn checkout of this
https://svn.blender.org/svnroot/bf-blender/trunk/lib/
in a seperate folder, but in the same directory as your branch source.

edit this will check out more files then you need. do either of these apply to you?

No, it’s not the first time I compiled.
What do I do with the svn checkout of the lib ?

I’m getting exactly the same error… somethings changed recently…is this a new dependancy?

nothing, it just needs to be there (at least for a windows build). If you’ve compiled before, then you must have the required libraries anyways :stuck_out_tongue:

also i idle in blendercoders sometimes, this was said a couple minutes ago :
[13:16] <lukep> kaito is there a reason for adding static libstdc++ ? Do we really want to add 6.5 Mb to the binary ?
[13:16] <kaito> lukep: it was based on player reports… but for blender it was not an issue
[13:17] <kaito> and 6.5 mb is quite some :confused:

sounds like its a new addition, perhaps not yet tested w/ your build system

I search my system and found the required librarie, but not in the folder where blender building system search for it.

Me too, I have the file , but not where scons is looking for it.
On my system libstdc++.a is at /usr/lib/gcc/x86_64-linux-gnu/4.1 [and 4.2 and 4.3].

After examination of diverse config files I tried something and IT WORKS !!!

My config-user.py is now:

CHOST=“i486-pc-linux-gnu”
CFLAGS="-march=i486 -O2 -pipe -fomit-frame-pointer"
CXXFLAGS="${CFLAGS}"

BF_OPENAL_LIB = ‘openal alut’

BF_CXX = ‘/usr/lib/gcc/i486-linux-gnu/3.4.6’
WITH_BF_STATICCXX = ‘false’
BF_CXX_LIB_STATIC = ‘${BF_CXX}/libstdc++.a’

WITH_BF_YAFRAY = ‘false’
WITH_BF_GAMEENGINE = ‘true’

I have another question: my CPU being a Pentium M are my flags correct ?

Thanks val that works for me too:-

BF_CXX = ‘/usr/lib/gcc/x86_64-linux-gnu/4.1’
WITH_BF_STATICCXX = ‘false’
BF_CXX_LIB_STATIC = ‘${BF_CXX}/libstdc++.a’

EDIT - Don’t know much about Pentium M but I use these for an Intel Core2:-

CCFLAGS.extend( [’-march=native’,’-O2’,’-pipe’])
CXXFLAGS.extend([’-march=native’,’-O2’,’-pipe’])

Looks like it’s fixed now…and fast too.

I’ve successfully upgraded my scons to the 1.1.0 and it builds:

  • blender 2.46 + farsthary volumetric patch
  • etch-a-ton branch revision 17245
  • sim physics branch revision 17245.

But for the trunk my compilation stop on the first step. Here is what I obtain:

[email protected]:~/blender-svn/blender$ scons
scons: Reading SConscript files …
Command-line arguments
No command-line arguments given
Command-line targets
No targets given, using default
Using config file: config/linux2-config.py
Using user-config file: user-config.py
Build with 1 parallel jobs

scons: warning: The env.Copy() method is deprecated; use the env.Clone() method instead.
File “/home/val/blender-svn/blender/SConstruct”, line 230, in <module>
Linux platform detected:
checking for FreeAlut… yes
Building in …/build/linux2/
Configuring library bf_soundsystem
Configuring library bf_string
Configuring library bf_ghost
Configuring library bf_guardedalloc
Configuring library bf_bmfont
Configuring library bf_moto
Configuring library blender_CTR
Configuring library bf_memutil
Configuring library bf_decimation
Configuring library bf_IK
Configuring library blender_bop
Configuring library blender_ONL
Configuring library bf_elbeem
Configuring library blender_BSP
Configuring library extern_glew
Configuring library extern_qhull
Configuring library extern_solid
Configuring library extern_bullet2linmath
Configuring library extern_bullet2dynamics
Configuring library extern_bullet2collision_broadphase
Configuring library extern_bullet2collision_dispatch
Configuring library extern_bullet2collision_gimpact
Configuring library extern_bullet2collision_shapes
Configuring library extern_bullet2collision_narrowphase
Configuring library extern_bullet2softbody
Configuring library extern_ftgl
Configuring libx264…
(skipped, config.mak already exists)
Processing makefile: extern/x264/config.mak
Processing makefile: extern/x264/Makefile
Configuring library extern_x264
Configuring libmp3lame…
Processing makefile: extern/libmp3lame/Makefile.am
Configuring library extern_libmp3lame
Configuring libxvidcore…
(skipped, build/generic/platform.inc already exists)
Processing makefile: extern/xvidcore/build/generic/sources.inc
Processing makefile: extern/xvidcore/build/generic/platform.inc
Configuring library extern_xvidcore
Configuring ffmpeg…
(skipped, config.mak already exists)
Processing makefile: extern/ffmpeg/config.mak
Processing makefile: extern/ffmpeg/libavformat/Makefile
Configuring library extern_libavformat
Processing makefile: extern/ffmpeg/config.mak
Processing makefile: extern/ffmpeg/libavcodec/Makefile
Configuring library extern_libavcodec
Processing makefile: extern/ffmpeg/config.mak
Processing makefile: extern/ffmpeg/libswscale/Makefile
Configuring library extern_libswscale
Processing makefile: extern/ffmpeg/config.mak
Processing makefile: extern/ffmpeg/libavutil/Makefile
Configuring library extern_libavutil
Configuring library extern_openjpeg
Configuring library extern_binreloc
Configuring library bf_avi
Configuring library bf_blenkernel
Configuring library bf_blenlib
Configuring library bf_blenloader
Configuring library bf_blenpluginapi
Configuring library bf_gpu
Configuring library bf_imbuf
Configuring library bf_cineon
Configuring library bf_dna
Configuring library blender_radiosity
Configuring library bf_readblenfile
Configuring library blender_render
Configuring library src
Configuring library nodes
Configuring library blender_python
Configuring library bf_ftfont
Configuring library bf_dds
Configuring library bf_openexr
Configuring library bf_kernel
Configuring library blender_creator
Configuring library bf_bloutines
Configuring library bf_converter
Configuring library bf_expressions
Configuring library bf_logic
Configuring library bf_ketsji
Configuring library kx_network
Configuring library bf_ngnetwork
Configuring library bf_loopbacknetwork
Configuring library bf_common
Configuring library bf_dummy
Configuring library bf_rasterizer
Configuring library bf_oglrasterizer
Configuring library bf_scenegraph
Configuring library bf_bullet
Configuring library bf_sumo
Configuring program blender
>>> …/install/linux2 release/freedesktop/icons/22x22 blender.xcf.bz2
>>> …/install/linux2 release/freedesktop/icons/22x22 blender.png
>>> …/install/linux2 release/freedesktop/icons/32x32 blender.svg
>>> …/install/linux2 release/freedesktop/icons/32x32 blender.png
>>> …/install/linux2 release/freedesktop/icons/16x16 blender.xcf.bz2
>>> …/install/linux2 release/freedesktop/icons/16x16 blender.png
>>> …/install/linux2 release/freedesktop/icons/scalable blender.svg
>>> …/install/linux2 release/plugins bmake
>>> …/install/linux2 release/plugins Makefile
>>> …/install/linux2 release/plugins/texture tiles.c
>>> …/install/linux2 release/plugins/texture clouds2.c
>>> …/install/linux2 release/plugins/texture Makefile
>>> …/install/linux2 release/plugins/sequence color-correction-hsv.c
>>> …/install/linux2 release/plugins/sequence gamma.c
>>> …/install/linux2 release/plugins/sequence dnr.c
>>> …/install/linux2 release/plugins/sequence blur.c
>>> …/install/linux2 release/plugins/sequence color-correction-yuv.c
>>> …/install/linux2 release/plugins/sequence scatter.c
>>> …/install/linux2 release/plugins/sequence Makefile
scons: done reading SConscript files.
scons: Building targets …
Compiling ==> ‘SND_DummyDevice.cpp’
cc1plus: attention : l’option de la ligne de commande “-Wdeclaration-after-statement” est valide pour C/ObjC mais pas pour C++
intern/SoundSystem/dummy/SND_DummyDevice.cpp:1: erreur: valeur erronée (i486 -O2 -pipe -fomit-frame-pointer) pour l’option -march=
intern/SoundSystem/dummy/SND_DummyDevice.cpp:1: erreur: valeur erronée (i486 -O2 -pipe -fomit-frame-pointer) pour l’option -mtune=
scons: *** [/home/val/blender-svn/build/linux2/intern/SoundSystem/dummy/SND_DummyDevice.o] Error 1
scons: building terminated because of errors.

Am I the only one to have this problem ? I am on Ubuntu 8.10

If you made a copy of an older version of linux2-config.py, check the C and C++ flag options. I made some changes to their handling, and your user-config.py, based on an older default config, doesn’t update properly with the newer way.

See your linux2-config.py and see C_WARN, CC_WARN, CXX_WARN, the release flags, the debug flags and the profile flags (if they’re not in your user-config.py, then you don’t have to check them).

/Nathan

jesterking can you give me/us a .txt of the userconfig.py you use to build blender for release or a userconfig options.txt?

I changed the flags relative to my processor, and now it works !

@alienkid10

The config I currently use is in a file called ‘msvc’ in the same dir as SConstruct. It contains:


WITH_BF_FFMPEG = True
WITH_BF_OPENAL = True
WITH_BF_PLAYER = True
WITH_BF_GAMEENGINE = True
WITH_BF_VERSE = True
WITH_BF_QUICKTIME = True
WITH_BF_DOCS=True
CCFLAGS = ['/nologo', '/Ob1', '/J', '/W3', '/Gd', '/MT', '/openmp']
BF_NUMJOBS=4

I start my Blender build process with: scons BF_CONFIG=msvc

Note the new BF_NUMJOBS=4. Give that the number of cores you have, and see fast builds :slight_smile:

/Nathan

so that should give me a release build? Could I just call it uesr-config.py and place it it the source files?